Manjaro KDE 64 and Fedora KDE 64 Dual Boot


My configuration is as follows:

  Kernel: 6.0.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.0-x86_64

  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux

  Type: Desktop System: LENOVO v: ideacentre AIO 310-20IAP

  Info: model: Intel Celeron J3355 bits: 64

I have a 1 TB HDD, and Manjaro is on a 330 GB partition (NO SWAP PARTITION)

I have one empty 330 GB partition and I want to keep it as is.

Rest 330 GB is unformatted space

What precautions to take before and while installing Fedora 64 bit (KDE) to the unformatted space. I don’t want to lose access to the Manjaro OS.

**What will happen to Manjaro GRUB when I install Fedora KDE 64 bit in the unformatted space using a Fedora KDE 64 installer USB drive?

I have taken fedora from the following link, so I guess it’s authentic:


I also want to be able to access my files in Manjaro (it’s not encrypted) when I boot into Fedora KDE 64.

Do’s and don’ts? Precautions? I’m a newbie to linux, sorry for such silly questions


well this should be more for the fedora forum, since thats what you are going to install… but nothing will happen to your files, you will be able to access them, and manjaro grub will be overwritten, and you will be using fedoras… and thats it…

1 Like

Thanks, Brahma. Will I be able to boot into Manjaro through the Fedora installed Grub?

just found this:

its over a year old, so dont know how accurate it is…

so you can try if it works with fedoras grub, and if not, you will have to reinstall manjaros grub, and using manjaros grub

1 Like

Brahma, I just booted into Fedora live USB and one of the install options is ‘Do not install bootloader’.

If I use this option and install Fedora, then perhaps the already working Manjaro Grub will recognise that Fedora is installed and add it to the boot menu on its own?

ok, that should work, you would be using manjaros grub, but im not 100 % sure… you will have to then run this command from manjaro to detect fedora:
sudo update-grub


Installed Fedora 36, using the ‘don’t install bootloader’ option from its live USB.

Manjaro Grub was undisturbed after reboot.

Then I ran sudo update-grub in Manjaro, it detected Fedora 36 but for some reason did not add it to grub.cfg

I ran update-grub several times. Same result as above.

Giving up on this. Not particularly keen on Fedora, was just curious.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.