Manjaro is stuck at load/boot screen on VirtualBox

I started exploring Manjaro in VirtualBox (Host, Windows 10).

I did a fresh install of Manjaro KDE and then installed multiple packages (the shell script that I used to install the package is hydro-manjaro-linux/00-install_my_packages at dev_testing · MIsmlAhmed/hydro-manjaro-linux · GitHub)

After installing all packages and restarting the system, it is stuck at the load screen (Manjaro logo with the three horizontal dots).

I am familiar with the RUB_CMDLINE_LINUX="ibt=off" flag, but it did not help.

I could not include detailed output, but the system is fresh (and my knowledge as well), all I did after installing the os is to run the shell script from the link above and the problem happened.
Any help will be greatly appreciated

Could you reach KDE before installing this script ?
If so, the issue is not on Manjaro side, and you should add an issue on github where your script comes from.

Before running the script, I could reach the login screen and the system worked very well.
The script is written by myself and it only installs software using yay -S command.

Then it is not Manjaro - but something you installed - right?

There is nothing in your script which stands out.

Your have some lines which can be reordered as they are overlapping each other and as I see it - it is a one time script

sudo pacman-mirrors --country Canada
#sudo pacman-mirrors -f 0           # remove this - it is overlapping line above
sudo pacman -Syyu --noconfirm       # execute this before installing yay
sudo pacman -S yay pamac --noconfirm
# yay -Syyua --noconfirm            # remove this - it overlaps the pacman sync command

I use something similar when I (re)set my primary system (FH / wonky-restore · GitLab)

A recommendation on troubleshooting this.

Refactor your script to

  • use pacman for repository packages
  • use yay only for the custom packages
  • install the list of custom packages at the end of the script

further trouble shooting

  • remove all custom packages

then reboot and start troubleshooting

I am not sure if that is caused by a package that I installed or not. Most likely, yes, but I can’t point to the specific package that caused the issue.

Thank you for code edits and suggestion. How can I know if the package is a repo or custom package to use either pacman or yay? Isn’t yay a wrapper that should work with both types of packages?

Sorry if my question seem very basic, but I am totally new to Manjaro.

You created the script - I assume you know which packages is repo and which is AUR.


Not sure - but if you don’t know
and run the install first through pacman (instead of yay) then you will know
… what fails (or make the install fail) is that the package in question is NOT in the repos …

Then you might try to install the rest via yay.

Keep in mind that things are constantly changing - packages are orphaned, moved from (Arch) repo to AUR - and maybe even the reverse.

Your script can’t be static and work forever.

copy paste missed something:

that parameter should go with all the others → to GRUB_CMDLINE_LINUX_DEFAULT
not separate

but since this is a VM it makes no sense in any case - unless you defined your (virtual) CPU just like the real life CPU’s that do need that parameter.
… don’t know whether that is even easily possible in VirtualBox …

of course it did not help - it’s totally useless in a VM

1 Like

Thank you all for your replies.
I will check the yay-pacman usage and test it out to make sure I use them properly.
I will let you know what I find.

I did a couple of tests:
Using KDE (fresh install of the os everytime)

  1. I tried to use pacman for official repo and pamac for AUR, and after installing all packages, Manjaro also got stuck on boot screen.

  2. Tried installing all packages from the pamac GUI and the same happened.

Using gnome

I installed Manjaro-gnome from the iso file and I ran the shell script from my github repo (that uses yay). Surprisingly, the OS worked perfectly after installing and booting/loading properly.

So, this tells me that the problem is specific to KDE.
Any idea how to report this or get it fixed on KDE?

After doing some debugging, the problem is in how VirtualBox configures the hardware for the virtual machine.
The Graphics Controller of the VirtualBox machine should be set to VBoxVGA. While this option is marked as invalud setting by the software, Manjaro runs smoothly without any probelm after assiging the proper setting.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.