Manjaro installer stuck on waiting for 1 module

I know people have had this problem before, but I’ve exhausted all my options.

So, I want a dual-boot drive with Windows 10 and Manjaro XFCE, I’ve already got Windows 10 installed and I’m currently running Manjaro on a flash drive. The first problem I had was the SSD not being recognised by either the Manjaro installer or GParted. I successfully followed a guide to switch the SSD from RAID to AHCI which I had seen on other peoples’ posts.

Everything seems to be working fine except the installer which gets stuck on waiting for 1 module. Other posts concerning this problem with the installer just resort to changing the SSD to AHCI from IDE/RAID but I’ve already done that. I’ve tried using Manjaro Architect but to be honest it’s rather complicated and I keep getting the error of failing to install ‘basepkgs’ (126).

Basically, with the SSD on AHCI the installer waits indefinitely for 1 module, and with the SSD on RAID the installer, and GParted, don’t recognise the SSD.

Using kernel version 510, laptop is Dell Inspiron 15 5000.

1 Like

Have you checked the SHA of the downloaded ISO and reflashed the flash drive?

2 Likes

The ISO’s hash hasn’t been changed and I’ve already retried using Rufus on the flash drive.

1 Like

try then with ventoy

Just tried using Ventoy, installer still doesn’t work

This is a common problem that has multiple posts that have been erroneously closed with a solution when that is very obviously not the case. Mods you need to review the other posts and reopen the ones that have been closed. We need a solid solution for this not someone who thinks their one solution is the only problem anyone will ever have.

A couple of those posts can be found below
https forum DOT manjaro DOT org /t/manjaro-kde-20-1-installation-stuck-at-waiting-for-1-module/39489
https forum DOT manjaro DOT org/t/cant-install-waiting-for-1-module/14861