Manjaro installer stuck on installing bootloader + GRUB not showing up


Before I explain the issue, just a bit of background. I was running a dual boot Windows/Manjaro installation. A few weeks ago, I was updating my Manjaro when my laptop ran out of battery (in my defense, i thought it was plugged in…). My system wasn’t booting so I followed one forum post from here that had had a similar issue and I ran these commands from a Live Manjaro USB:

sudo su -
manjaro-chroot -a


pacman-mirrors -f 5 && pacman -Syyu 
systemctl reboot

The update finished succesfully, i guess, (although I had to add -- force to the update command), but when I tried to reboot, my GRUB was not showing up and I was sent directly to the BIOS whenever I tried to boot up.

Since my PC was unusable, and I have been waiting to add another SSD, I thought I could add the new SSD, make a fresh installation and then move all my data back from the old hard drive. But when I try to do this and run the installer, it just got stuck on “install bootloader” 90%

I honestly don’t know what to do right now. Any ideas?

Thanks in advance!