Manjaro i3 Wifi Problem -- Fresh Install


I am in the process of setting up a dual boot of Windows 11 and Manjaro i3, on a Lenovo T14 Gen 3, (AMD). I have scoured the internet searching for solutions, but haven’t found one yet. Some help would be much appreciated!

Here is the output of inxi -Fazy:

  Kernel: 5.15.74-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=3afe7222-2920-4bf6-8be4-c4553bc4458b rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: i3 v: 4.21 info: i3bar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 21CF003YUS v: ThinkPad T14 Gen 3
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21CF003YUS v: ThinkPad serial: <superuser required>
    UEFI: LENOVO v: R23ET60W (1.30 ) date: 09/14/2022
  ID-1: BAT0 charge: 39.3 Wh (100.0%) condition: 39.3/39.3 Wh (100.0%)
    volts: 13.3 min: 11.6 model: LGES LNV-5B10W51860Àà type: Li-poly
    serial: <filter> status: full cycles: 3
  Info: model: AMD Ryzen 7 PRO 6850U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check built: 2022
    process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x44 (68) stepping: 1
    microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1742 high: 2314 min/max: 1600/4767 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1801 2: 2094
    3: 1735 4: 1428 5: 2314 6: 1509 7: 1414 8: 1551 9: 1366 10: 1552 11: 1825
    12: 1805 13: 1747 14: 2096 15: 1548 16: 2095 bogomips: 86258
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 45.0 C
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 5-1:2 chip-ID: 174f:1812 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-7e568
    driver: X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 mapped: eDP model-id: CTO 0x1416 built: 2020
    res: 1920x1200 hz: 60 dpi: 162 gamma: 1.2 size: 301x188mm (11.85x7.4")
    diag: 355mm (14") ratio: 16:10 modes: max: 1920x1200 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.15.74-3-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm QCNFA765 Wireless Network Adapter vendor: Lenovo
    driver: N/A modules: ath11k_pci pcie: gen: 2 speed: 5 GT/s lanes: 1
    link-max: gen: 3 speed: 8 GT/s bus-ID: 02:00.0 chip-ID: 17cb:1103
    class-ID: 0280
  Device-1: USI type: USB driver: btusb v: 0.8 bus-ID: 1-3.1:3
    chip-ID: 10ab:9309 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 9.73 GiB (1.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk
    model: SKHynix HFS001TEJ9X102N size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 51720A10 temp: 39.9 C scheme: GPT
  ID-1: / raw-size: 732.42 GiB size: 719.86 GiB (98.28%) used: 9.7 GiB (1.3%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 33.3 MiB
    (13.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): fan-1: 0
  Processes: 289 Uptime: 57m wakeups: 5906 Memory: 30.13 GiB used: 1.49 GiB
  (4.9%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1103 libs: 330
  tools: pamac,yay Shell: Bash v: 5.1.16 running-in: urxvtd inxi: 3.3.22

Here is the output of uname -a

Linux rolandT14 5.15.74-3-MANJARO #1 SMP PREEMPT Sat Oct 15 13:39:11 UTC 2022 x86_64 GNU/Linux

I have installed the proper Linux headers:

core/linux515-headers 5.15.74-3 [installed]

One thing I have noticed about my problem that is different from others I have encountered online is the output of rfkill list all:

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no

In other posts, there is usually some item representing Wlan.

It should not be a hardware problem, as Wifi works perfectly in my windows partition. I have disabled fast startup in the windows partition, and secure boot is off in the BIOS.

Most of the posts I have seen are solved by installing some realtek driver. I have looked for drivers corresponding to this Qualcomm device, and have stumbled upon a little documentation on linux-hardware. I can’t include links, but if you search linux-hardware with Qualcomm QCNFA765 it should come up. It seems that the device works with versions 5.14 - 6.0 (I am running 5.15). I believe my install should have come with ath11k.

Any help solving this problem is appreciated! Cheers

Edit: Some extra information –

Ethernet is working well. If I run nmcli dev wifi rescan I get

Error: No Wi-Fi device found.

Some things to try:

Update to the latest stable kernel: 6.0.6 currently

You might need to install the linux-firmware-qcom package to get the correct software support for your hardware.

I did both of these, and now I have Wifi! Thanks for your time!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.