Manjaro i3 in virtualbox - forced to restart i3 to refresh screen content

Hello everyone,

I run Manjaro KDE on my laptop and I am running VirtualBox on this machine. I created a virtual machine and I gave it half my ram (4GB out of 8) and half my CPU cores (4GB out of 8) and I installed Manjaro i3 in the VM.

The problem I have is that part of the content of the windows in i3 on the VM does not display unless I restart i3 (mod+shift+R). For instance, if I open a terminal window, the window does appear but the content of the window is not displayed. If I use the keyboard shortcut to restart i3, I can then see the content of the terminal window. If I start typing something in the terminal window, nothing new is displayed on the screen but then if I restart i3 again, what I typed previously in the terminal is now correctly displayed.

I am not sure whether this issue is i3 or virtualbox related but I never encountered any similar issues with i3 and I am new to virtualbox so my guess is that I have a problem with virtualbox. Any help would be greatly appreciated.

Thanks for reading me.


It seems this is related to the video driver.
In virtualbox you could try to choose another.

What I just did was:
edit the configuration for the compositor (picom).


nano ~/.config/picom.conf

backend = "glx"
backend = "xrender"

That seems to have done the trick for me in Virt-manager.


It worked. Thank you very much.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.