Manjaro Hybrid GPU Boot Stuck issue

I am completely new to the Linux community and for my usage, I just love how flexible Manjaro is!

But I am facing the following issues which are very irritating :confused:

  1. At the very first, my laptop will sometimes (4 times out of 5) get stuck in the boot logo. Sometimes it boots and other times I need to shut down and try again to boot. I tried to edit the boot settings from GRUB to see what is wrong and I found out that when it does not boot, it gets stopped at this line: “Nvidia can’t change power state from D3cold to D0 (config space inaccessible)”. I tried searching to fix this issue but could not find any.
  2. So I installed optimus and optimus qt to switch GPU and it set my default GPU to intel. This solved problem 1 completely and I could boot every time but when I try to shift from intel to hybrid/dedicated Nvidia, the software restarts the UI but does not change the gpu.
  3. I tried uninstalling it and installing again but now I am in a boot loop that I don’t know how to solve.

I am okay in flashing Manjaro again as I love the OS so much but can someone guide me properly how to setup the dual GPU thingy? I just want Nvidia to kick when I run something GPU intensive such as video editing software or Games from Steam and other sources.

Just to note, I have windows 10 in a separate drive in the same laptop.

My specs:

Intel core i7 9760H

16 GB DDR4 RAM

Nvidia 1650 Max Q and intel HD 630