Manjaro has been very laggy and irresponsive on Laptop

I recently installed manjaro on my Laptop Dell Inspiron 5577. It has Nvidia GTX 1050 Graphic card, I had checked non open source drivers during installation process and I had video-hybrid-intel-nvidia-455xx prime initially, and Im using 5.9.8-2 Kernel currently.

I think I have installed the system with UEFI Mode + Legacy PROM and with secure boot mode off. (Not sure though, bit noob in all this)

My system has 24 gb Ram and 512 GB SSD. I Have given around 90 gb of ssd for root and 90 gb HDD for /home. I really don’t understand why the system feels so laggy and irresponsive. When I open any application it opens after a delay and sometimes doesnt open at all and suddenly opens at one time with too many instances.

I had given around 4 GB Swap space since I had sufficient Ram, I tried lot of things but none have worked so far, I really love the KDE Experience and the Arch Linux Experience, thus I do not want to leave Manjaro, can anyone help me troubleshoot my problem, I would really appreciate it.

Also I changed the compositor to open GL 3 still I dont find much difference. I tried to use different driver version (450xx-prime) but the performance is still very bad.

Output of

> mhwd -li
Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    > video-hybrid-intel-nvidia-450xx-prime            2020.10.04               false            PCI
    >      video-modesetting            2020.01.13                true            PCI

`Warning: No installed USB configs!`

Output of 
`cat /etc/X11/mhwd.d/nvidia.conf`
> ##
> ## Generated by mhwd - Manjaro Hardware Detection
> ##
output of

> inxi -Fza

> System:
>   Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
>   parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
>   root=UUID=8ecb3934-dc3f-4f4c-b8da-7691a26c44a8 rw quiet apparmor=1 
>   security=apparmor resume=UUID=e86b2141-311a-4086-bf67-b0efe4674436 
>   udev.log_priority=3 
>   Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 
>   dm: SDDM Distro: Manjaro Linux 
> Machine:
>   Type: Laptop System: Dell product: Inspiron 5577 v: 1.0.8 
>   serial: <filter> Chassis: type: 10 serial: <filter> 
>   Mobo: Dell model: 0MVD5F v: A00 serial: <filter> UEFI: Dell v: 1.0.8 
>   date: 12/13/2017 
> Battery:
>   ID-1: BAT0 charge: 50.0 Wh condition: 50.0/74.0 Wh (68%) 
>   volts: 12.7/11.1 model: SDI Dell type: Li-ion serial: <filter> 
>   status: Full 
> CPU:
>   Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
>   arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE 
>   L2 cache: 6144 KiB 
>   flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
>   bogomips: 44817 
>   Speed: 863 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 835 2: 896 
>   3: 836 4: 896 5: 894 6: 802 7: 854 8: 806 
>   Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
>   Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
>   SMT vulnerable 
>   Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
>   Type: meltdown mitigation: PTI 
>   Type: spec_store_bypass 
>   mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>   Type: spectre_v1 
>   mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>   Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
>   IBRS_FW, STIBP: conditional, RSB filling 
>   Type: srbds mitigation: Microcode 
>   Type: tsx_async_abort status: Not affected 
> Graphics:
>   Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
>   bus ID: 00:02.0 chip ID: 8086:591b 
>   Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell 
>   driver: nvidia v: 450.80.02 alternate: nouveau,nvidia_drm 
>   bus ID: 01:00.0 chip ID: 10de:1c8d 
>   Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB 
>   driver: uvcvideo bus ID: 1-4:4 chip ID: 1bcf:2b8a 
>   Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
>   driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
>   display ID: :0 screens: 1 
>   Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
>   s-diag: 582mm (22.9") 
>   Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 
>   size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
>   OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) 
>   v: 4.6 Mesa 20.2.2 direct render: Yes 
> Audio:
>   Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel 
>   v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
>   Sound Server: ALSA v: k5.9.8-2-MANJARO 
> Network:
>   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
>   vendor: Dell driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
>   chip ID: 10ec:8168 
>   IF: enp2s0 state: down mac: <filter> 
>   Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 
>   bus ID: 03:00.0 chip ID: 8086:3165 
>   IF: wlp3s0 state: up mac: <filter> 
> Drives:
>   Local Storage: total: 1.36 TiB used: 22.16 GiB (1.6%) 
>   SMART Message: Unable to run smartctl. Root privileges required. 
>   ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3X0C-00SJG0 
>   size: 465.76 GiB block size: physical: 512 B logical: 512 B 
>   speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 102000WD scheme: GPT 
>   ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 
>   size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
>   speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM2 
>   scheme: GPT 
> Partition:
>   ID-1: / raw size: 97.35 GiB size: 95.33 GiB (97.92%) 
>   used: 13.62 GiB (14.3%) fs: ext4 dev: /dev/nvme0n1p7 
>   ID-2: /home raw size: 93.66 GiB size: 91.69 GiB (97.90%) 
>   used: 8.54 GiB (9.3%) fs: ext4 dev: /dev/sda4 
> Swap:
>   Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
>   ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) 
>   priority: -2 dev: /dev/sda3 
> Sensors:
>   System Temperatures: cpu: 62.0 C mobo: N/A sodimm: 47.0 C 
>   Fan Speeds (RPM): cpu: 1940 
> Info:
>   Processes: 269 Uptime: 25m Memory: 23.26 GiB used: 3.03 GiB (13.0%) 
>   Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1268 
>   lib: 335 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
>   inxi: 3.1.08

referring to the title

NO Manjaro is not irresponsive and laggy.

I can’t say anything for your hardware - but generally speaking - you shouldn’t experience lags and ir-responsiveness.

What ever it is - it is a matter of configuration - example using opensource driver for Nvidia. Depending on the actual Nvidia chip and the driver - even I have experienced these lags.

Please - don’t use such sentences - if you can’t make it work - it is likely not Manjaro but a general system issue.

I have been over - almost every default config on Manjaro - and none of any configs were bad at initial install.

However some of the popular configs seems to - within a short time frame - become a somewhat pain - but I don’t think this is Manjaro - it is a general problem although many users seems to think it is a Manjaro issue.

Before you complain on Manjaro - please try any other distribution using the same desktop environment.

I am quite sure you will find the issue is not Manjaro specific - but more of a desktop issue.

I can tell you that I - the last couple of years - has been running Manjaro systems from 16G memory to my current 64G memory system. The last system is running Nvidia Quadro P2000 with the proprietary driver on 5.10 (rc4) and I have no issues.

I don’t know if the reason is my customization.

When I use Openbox WM and picom as compositor - it is hmm… - but when using compiz - it is a completely different matter.

So my advise here is - don’t rely on the default configs - find the configuration that works for you - make notes of your config changes - so you will know exactly what works and what not.

Hi, Thank you for the reply, I did not mean to associate the problem with Manjaro but its just that I’m not actually well versed in Linux and hence I don’t know what exactly to tweak or change so that I get improvement.
I’m coming from Ubuntu actually and my system was smooth and lag free most of the times and relatively less crashes there, but due to this sudden change to Manjaro recently, I can experience the laggy and delayed responses. I’m not able to work properly at all, even running code cells in Jupyter notebooks (I have installed anaconda) takes very long time, I was frustrated with this today.

I have checked few other articles regarding this and hence I posted whatever output which maybe required to debug the issue. I would really appreciate it if anyone could let me know what is the reason for the system being so laggy in my case. I have configured my system by following a youtube tutorial (adding latte doc, some widgets like active window control etc, changing themes), but I’m not sure if thats the reason for all these problems?

So should I try using open source driver for Nvidia as you suggested and see if it makes a difference?
I have not used any other distro with KDE before this, and currently I feel really lazy and also have space constraints to try out any other new linux installation, I really love the level of customization in KDE and thus would not want to sacrifice it.

I can’t say what is working for your system - those Dell laptops - although claimed differently sometimes - most often is built with Windows in mind.

What I am saying - is that you need to figure out what works for your system - don’t depend on defaults because they are not always the right one.

That might be your problem …

Yeah but, I did not face much issues in Ubuntu and the performance felt smooth there. Probably because of GNOME DE.
I feel like I still have lot to learn about Linux and gain more experience in using Linux before I can start customizing configurations on my own. Anyways, thank you for your time and the reply, would try to see if I figure out something.