Manjaro has become unresponsive & unstable

Hi folks! I’m having some problems with Manjaro. I have no idea what caused/triggered this problem. I did not change anything. I didn’t update anything. There was no system update either.

Screen was turned off due to inactivity as I set it up to turn off screen in “Energy Savings” setting. That’s been my settings for months without any issue. I don’t think my current issue is related to this.

A few hours later, when I was back on the computer, there was a “Notifier” icon in the “System Tray”, next to the bluetooth icon. When I hovered over the notifier icon, it disappeared.

When I hovered over other icons (bluetooth, screen brightness, volume, battery, networks) in the system tray, they disappeared too.

I restarted the computer. It didn’t help! I restarted, choosing a different kernel. It didn’t help either.

Maybe it was the same or another notifier icon in the system tray, when I clicked on it, small option window popped up, to select some options, I think it was about rendering if I remember correctly.

There were some options, Vulkan, OpenGL (and some other ones I don’t really remember). I chose “Vulkan”, which made things worse.

Now the application launcher doesn’t respond as if it were frozen. The semi-transparent panel turns black. Once I launch any app, I can’t exit out. It doesn’t respond. It may be due to kwin_x11 crash.

I tried to find and launch the setting for the notifier, which I recently changed to “Vulkan”, but I could not find any options or settings to make the change. Any help is greatly appreciated.

A couple of possible suggestions: have you tried removing the panel and creating a new one; also have you tried a Wayland session?

I suspect some panel setting(s) have been corrupted, somehow.

Also, in Konsole (or Yakuake via F12) try running e.g. htop to see if there are processes hogging the system.

1 Like

I can only remember 2 situation’s where i saw a message pop ups there.

  1. After a Desktop crash or switching between TTY & Desktop forth and back, that the Desktop session was restored.

or

  1. That my battery on my Laptop is Low.

For the next time, create a timeshift snapshot and restore your working system. I know this doesn’t help you right now :wink:

:crazy_face:

From my understanding, Vulkan is a option for 3D Application’s for Hardware acceleration. Possible you mistaken it with Wayland? Which can be switched in SDDM (Log-in Menue at the bottom left)

2 Likes

After running htop, it shows line after line,

/usr/bin/kwin_x11 --crash
.
.
/usr/bin/kwin_x11 --replace
.
.

I just tried Wayland. Wayland session seemed fine. I rebooted and logged back in to my X11 session, which is the one I use. X11 session seems to be fine now. I don’t know how, but logging in to Wayland session must have or seems to have reset or refreshed or replaced something in X11 session. To be sure, I need to use the system for a few days to see if any issue comes up! I’ll report back.

Thanks!

1 Like

I do have a TimeShift backup, but as a general rule, I’d rather hold off on resorting to TimeShift backup until/unless the problem is a major one!

Well, I was simply referring to the initial problem. Nothing was done or changed to trigger the initial problem prior to changing the setting to “Vulkan”.

I’m going to try to see if I can find out what that “rendering” thing was. Stay tuned! :wink:

1 Like

Did you used Timeshift before this day? Could this probably the reason why you evade the rollback function?

I mean its understandable, when you don’t used it yet.
That you fear it because you don’t know if you can rely on it.

From SSD wear perspective i have the same viewpoint to evade it, when its possible.

But the point is that you don’t really remember which changes you did to your system and if you compare the time difference (wasted time). Even if you lucky to find the error and solved it right now or the amount of time that you put to find this error and it stays unsolved.

Compared to a Timeshift rollback, which probably only takes 10min to boot in a live boot and start timeshift GUI and choose your snapshot, only to follow the easy steps from the super userfriendly GUI. Should be a clear winner here, since you did a goodjob and have a timeshift snapshot (i hope Rsync) right in front of you. This is the situation where you actually could use it.

Or are there other things that hold you off, which make it more difficult to going this way? Like Btrfs, Root Encryption or a enormous big Root Partition?

1 Like

Manjaro has become unresponsive & unstable

So, it has become either:

  • Stable in its unresponsiveness; or
  • unresponsive in its stableness.

Because the double negative says it has become Unstably Unresponsive, so stable and responsive.

I couldn’t help myself. Sorry, not sorry. I’ll let myself out.

2 Likes