Manjaro hanging after latest update


After latest update, my OS has become unresponsive. I can sometimes get a terminal to open, but browser hangs (won’t open at all) and then nothing is clickable, so I have to switch off the PC. It’s all just frozen.

I did manage to open a terminal window and tried to edit the etc/default/grub to change the grub timeout from hidden to menu, with a view to reverting to an older version of Manjaro, as I was shown on this forum. Unfortunately, I have made matters worse for myself by deleting something unknown or changing something in the etc/default/grub by mistake.

I tried timeshift when I managed to get it working, but it froze on a dry run comparing files.

Advice and assistance greatly appreciated.

I may be away from my computer for a few days, so if you respond and I don’t, I apologise and thank you for your patience and guidance.

manjaro /]# mhwd-kernel -li
Currently running: 5.15.48-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux61

from chroot rerun update:

pacman-mirrors --fasttrack 5 && pacman -Syyu

if there were no errors, and you are up to date, post output from:
cat /etc/default/grub

and you can run timeshift from live usb…

Thanks, brahma. Apologies for the delayed response.

I have updated the system and mirrors as per instruction and there were no errors.

manjaro /]# cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 ibt=off" 

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Uncomment to disable submenus in boot menu

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:
[manjaro /]#

I should add I currently do have a grub menu on boot, but it only gives me the one version of Manjaro to boot.

gurb looks ok…
what one version? do you have more manjaro versions?
did you timeshifted from live usb?

Thanks, brahma.

So do I go manjaro-chroot -a and then do the timeshift?

Can I do it via the gui? If I need to do it through the cli, when choosing GRUB device, do I choose the MBR and not the ext. 4?

Thanks for your assistance.

The version is LInux61. Previously I had an earlier LTS version to downgrade to and it solved my problem. This time the grub menu only offered one version, only LInux61 installed.

no you dont need to chroot… just open timeshift in the live usb (the gui, no need to use cli if you dont want too), mount the partition where you have the snapshots and thats it…

but first lets try this:

so before using timeshift, install the 5.15 kernel, you do this from chroot:
mhwd-kernel -i linux515
if there were no errors, reboot and try booting with it… maybe those freezes are a kernel thing, and using different one will resolve it…

This is what I got:

[manjaro /]# mhwd-kernel -i linux515
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update.

I may have given you wrong information about the version. I will exit live usb now to get you the right information about what I am seeing on my main system.

this is because kernel 5.15 is used by the live usb, so from chroot:
pacman -S linux515

I may be in trouble.

I went to the main system now and saw it was inaccessible, it looks like it is in kernel panic. This may or may not have to do with a previous failed timeshift attempt, although there were warning signs much earlier.

manjaro /]# pacman -S linux515
pacman: error while loading shared libraries: cannot open shared object file: No such file or directory

from chroot:
pacman -S gpgme --overwrite '*'
if no errors, then install kernel:
pacman -S linux515

Wow. I was for a few moments unable to use the reply to the forum. The error was 429 Too Many Requests. As for my system…

manjaro /]# pacman -S gpgme --overwrite '*'
pacman: error while loading shared libraries: cannot open shared object file: No such file or directory

post output from:
pacman -Qo /usr/lib/
and also output from the chroot command

[manjaro /]# manjaro-chroot -a
bash: manjaro-chroot: command not found

manjaro /]# pacman -Qo /usr/lib/
pacman: error while loading shared libraries: cannot open shared object file: No such file or directory
[manjaro /]#

i didnt meant to run manjaro-chroot -a again… you are already chrooted, so locate the output from it, and post it here, so that i can see where your manjaro partition is located… or post output from:

[manjaro /]#

so which one is manjaro?

I don’t really know. I’m quite novice.

I don’t have a dual-boot system, so I think manjaro must be the ext 4. If I open in Gparted, I see ``/dev/nvem0n1p2 as the root partition.