Manjaro Gnome random freeze

Hi guys!
I recently installed manjaro gnome on an old windows tablet I have.
Despite the low ram and generally low power of this machine, almost everything worked very well out of the box.
I’m experiencing random freezes though: it doesn’t seem to be a specific application or process that causes the system to freeze and it doesn’t happen very often either. The tablet still suspend and wakes up if I press the power button but I can’t login or even safely reboot, the only option I have is an hard reboot. Another curious thing is that even though I can’t interact with the desktop at all, the clock and battery indicator still work fine, as if they’re not affected by it.
I’ve looked up other threads in the forum but they focus on other desktops or are related to nvidia drivers so they don’t apply to me and I don’t have the necessary troubleshooting skill to figure it out myself.
Wat can be the problem here?

here’s my inxi -Fazy, tell me if you need anything else

  Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=ea016338-d0b2-4a65-8848-dd3d0c40ee37 rw quiet apparmor=1 
  security=apparmor resume=UUID=e780fae1-bd59-428b-b636-b1673e36a737 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.1 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire P3-171 v: V2.04 serial: <filter> 
  Mobo: Acer model: Sage2 v: Type2 - A01 Board Version serial: <filter> 
  UEFI: Insyde v: 2.04 date: 06/24/2013 
  ID-1: BAT1 charge: 21.1 Wh condition: 34.1/40.1 Wh (85%) volts: 7.6/7.6 
  model: SANYO AP13A3L type: Li-ion serial: <filter> status: Discharging 
  Info: Dual Core model: Intel Core i3-3229Y bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11179 
  Speed: 1310 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 1320 2: 1360 
  3: 1397 4: 1410 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0166 
  Device-2: Sunplus Innovation type: USB driver: uvcvideo bus ID: 1-1.1:3 
  chip ID: 1bcf:2c46 
  Device-3: Alcor Micro HD WebCam type: USB driver: uvcvideo bus ID: 2-1:2 
  chip ID: 058f:b201 serial: <filter> 
  Display: wayland server: 1.20.9 compositor: gnome-shell driver: i915 
  note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.74-1-MANJARO 
  Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: 2040 bus ID: 01:00.0 chip ID: 168c:0034 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 55.90 GiB used: 10.92 GiB (19.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Intel model: SSDMCEAC060B3A size: 55.90 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: LLLi scheme: GPT 
  ID-1: / raw size: 51.75 GiB size: 50.69 GiB (97.95%) used: 10.67 GiB (21.0%) 
  fs: ext4 dev: /dev/sda2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3.86 GiB used: 262.8 MiB (6.7%) 
  priority: -2 dev: /dev/sda3 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 199 Uptime: 11m Memory: 1.76 GiB used: 1.27 GiB (72.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1287 lib: 353 
  flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08

ps: I know 2 gigs of ram it’s not the best for gnome, but I intend to use this pc for manly reading documents, pdf and light browsing so I didn’t want to go through the pain of configuring KDE to work well with the touchscreen (still my favourite DE nonetheless XD)

2Gb can be enough for gnome if you configure it right and do only light tasks as you planned.

Do you have swap configured? If not, I recommend using a swapfile, as running out of ram is one possible cause for system freezes.

I also recommend using as few shell extensions as possible for maximum stability. Shell and gtk theme adwaita-maia can also be good for tablets, bacause of the larger titlebars.

To reduce ram usage, avoid using gnome-online-accounts and uninstall evolution-data-server. This will take gnome-calendar and geary with it, but it can about halve the idle ram usage of the desktop. Also make sure you are not using dynamic wallpaper, because it consumes about 300-400Mb ram for very little benefit.

I would start with those, and move to the actual troubleshooting of the freezes then, if the issue persists. In gnome, the solution to most problems is usually “go as vanilla as possible”.


Thank you for your attention and sorry for the late reply…
I’ll sure try out what you told me, but this afternoon I was able to track down whats causing the freeze, although I really don’t know why.
This afternoon it happened 4 times that the system froze up when I opened the default file manager… a couple of times I just downloaded some files and I wanted to open them, the other times it froze just by clicking on the icon…
This is very strange, any ideas?XD

Also, I swap configured, 4 gigs in total and the I noticed that the system use it regularly, so no problem with that!


Little update:
this afternoon I tried to track down what was causing the freezing issue on this tablet and I think I found a solution.
I witched from Wayland to Xorg at login and it all seems fine now, the system feels snappier and it hasn’t froze for a while. I tried changing kernel but that didn’t help, in fact every Kernel except 5.4 LTS froze as soon as I clicked an icon!
So yeah, if anyone has this problem, unless you really wanna use wayland, this might be a solution for you!

If you are on a tablet like me and you installed iio-sensor-proxy for screen rotation, switching to xorg killed it for me. The solution is to install screenrotator package and screen rotation will work again!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.