Manjaro Gnome (on Wayland) freezes on login using AMD Graphics

Hello there,
I’ll try to be as quickly as possible

problems i had
I recently updated to the latest stable version available, and it didn’t go very well at all. After updating, I noticed some applications were correctly updated, like pamac, and I thought everything was fine, but after rebooting and logging into a new session, my machine froze and I was left with a grey background, where I could still see the pointer, but couldn’t move it.

Luckily for me I use timeshift, so I reverted to the last available snapshot (it’s Manjaro 20.05)

solutions i tried

  1. making as much space as possible to avoid partial update, and trying to update again
  2. downloading the latest available ISO, and do a clean installation

you guessed it – both ended up with the same grey screen

other weird problems
I haven’t been able to login into a Xorg session for quite some time, and I don’t know the reason, never bothered to check

last thing you need to know
After updating to Manjaro 20.05, I experienced the same issue, and it was related to my SSD. Adding the following kernel boot parameters fixed it: nvme_core.default_ps_max_latency_us=14000 and radeon.modeset=1

here’s the output of inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 5.12.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=ed67ac47-70a6-4d76-9a54-a2445101cc2d rw quiet splash 
  nvme_core.default_ps_max_latency_us=14000 apparmor=1 security=apparmor 
  udev.log_priority=3 radeon.modeset=1 foo=bar 
  Console: tty 2 DM: GDM 40.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Acer product: Swift SF314-41 v: V1.10 serial: <filter> 
  Mobo: PK model: Strongbow_PK v: V1.10 serial: <filter> UEFI: Insyde v: 1.10 
  date: 03/17/2021 
  ID-1: BAT0 charge: 33.0 Wh (73.0%) condition: 45.2/47.8 Wh (94.5%) 
  volts: 11.8 min: 11.2 model: LGC KT0030G020 type: Li-ion serial: <filter> 
  status: Discharging 
  RAM: total: 9.71 GiB used: 875 MiB (8.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108109 cache: L2: 2 MiB bogomips: 33550 
  Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1222 2: 1221 3: 1219 4: 1221 5: 1222 6: 1221 7: 1261 8: 1332 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Picasso vendor: Acer Incorporated ALI driver: amdgpu v: kernel 
  bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-4:3 
  chip-ID: 04f2:b5c5 class-ID: 0e02 serial: <filter> 
  Display: server: 1.20.11 compositor: gnome-shell driver: loaded: vesa 
  tty: 240x67 
  Message: Advanced graphics data unavailable in console. Try -G --display 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: snd_pci_acp3x v: kernel 
  alternate: snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 
  class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel bus-ID: 01:00.0 
  chip-ID: 168c:003e class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 3-2.4:4 
  chip-ID: 04ca:3016 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
  Permissions: Unable to run lvs. Root privileges required. 
  Message: No RAID data found. 
  Local Storage: total: 476.94 GiB used: 323.18 GiB (67.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN520 SDAPNUW-512G-1014 size: 476.94 GiB block-size: 
  physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 rotation: SSD 
  serial: <filter> rev: 20110000 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 250 GiB size: 245.02 GiB (98.01%) used: 199.51 GiB (81.4%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A 
  uuid: ed67ac47-70a6-4d76-9a54-a2445101cc2d 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.3 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4 
  label: N/A uuid: 12B0-3373 
  ID-3: /mnt/D684B21C84B1FF55 raw-size: 212.83 GiB size: 212.83 GiB (100.00%) 
  used: 123.65 GiB (58.1%) fs: fuseblk dev: /dev/nvme0n1p6 maj-min: 259:6 
  label: N/A uuid: D684B21C84B1FF55 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 13 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 27993cc5-534a-49db-9e32-40b32606f0e8 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 512 MiB fs: <superuser required> 
  label: N/A uuid: 85B3-8AF4 
  ID-2: /dev/nvme0n1p5 maj-min: 259:5 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p7 maj-min: 259:7 size: 505 MiB fs: <superuser required> 
  label: N/A uuid: 2852D21552D1E818 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: Logitech G203 Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c084 class-ID: 0300 serial: <filter> 
  Device-2: 1-4:3 info: Chicony HD WebCam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b5c5 
  class-ID: 0e02 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 3-2:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0608 class-ID: 0900 
  Device-1: 3-2.3:3 info: LighTuning EgisTec Touch Fingerprint Sensor 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 1c7a:0570 class-ID: 0000 serial: <filter> 
  Device-2: 3-2.4:4 info: Lite-On type: Bluetooth driver: btusb interfaces: 2 
  rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 04ca:3016 class-ID: e001 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 44.0 C mobo: 30.0 C gpu: amdgpu temp: 44.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 228 Uptime: 9m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1287 pacman: 1275 lib: 299 flatpak: 8 
  snap: 4 Shell: Zsh (login) v: 5.8 running-in: tty 2 inxi: 3.3.05 

Thanks for reading, any suggestion?

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. Can you still log in to TTY2 and provide a

    journalctl --system --boot=0 --priority=3 | tail --lines=35

    after the grey background happens?

    If not:

    • REISUB with a bootable USB
    • chroot into the existing install
    • provide same but from --boot=-1


P.S. If some of the above sounds like gobbledygook, please shout out!

Maybe try reverting the kernel flags you added before and/or try booting a different kernel.

Pamac 10 still uses GTK3, FYI. Version 11 will use GTK4.

1 Like

thought it was gtk4 since it looked fancy… still the point is, i updated correctly the os

i tried with booting with the following kernels 5.4, 5.12, with and without the parameters i added, with and without the “fallback” image

removing the flags i added resulted in my pc freezing during the systemd screen
everything else resulted in my pc freezing after login

  1. i did my homework and read the guide, thanks for sharing
  2. alright i edited my topic

nope i can’t do that

there you go

May 10 10:46:03 muddica-atturrata kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
May 10 10:46:05 muddica-atturrata systemd-backlight[821]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
May 10 10:46:05 muddica-atturrata systemd-backlight[822]: amdgpu_bl0: Failed to write system 'brightness' attribute: No such device or address
May 10 10:46:05 muddica-atturrata systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
May 10 10:46:05 muddica-atturrata systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.
May 10 10:46:16 muddica-atturrata gdm-password][1338]: gkr-pam: unable to locate daemon control file
May 10 10:46:25 muddica-atturrata gdm[818]: Gdm: Failed to contact accountsservice: Error calling StartServiceByName for org.freedesktop.Accounts: Refusing activation, D-Bus is shutting down.```

Install kernel 5.10 LTS and try again

If that doesn’t help,

  1. Execute:

    sudo nano /etc/default/grub
  2. add iommu=soft to the end of the line beginning with GRUB_CMDLINE_LINUX=

  3. Execute:

    sudo update-grub
  4. Reboot


using the 5.10 kernel made no difference at all, and so did appending the parameter you said

I chrooted into my current (not working) manjaro just out of curiosity and noticed that nothing changed, isn’t it weird these logs are stuck on the 10th of May?

I’ve exhausted all my AMDGPU knowledge as I’m an nVidia user myself, so the only thing I can do for you is to edit your title and add the #amdgpu tag and hope this attracts more knowledgeable people than me…


1 Like

it’s okay I really appreciated your help :watermelon:

1 Like

The problem didn’t lie on Linux at all, but rather on the BIOS update Acer released for this computer. I had to revert to the oldest version available to get Manjaro and every other distribution to actually run, thanks everyone for participating!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.