Manjaro Gnome on Lenovo Yoga 500 (Nvidia 920MX)

Hi there. I have a Lenovo Yoga 500 (i5-6200U, 4GB RAM, HD520, 920MX). I am trying to install Manjaro GNOME on it. I live booted using proprietary drivers, installed, and the first boot worked. But, after that, the login does not work. I enter my password, and it just returns me to the login menu. I tried modifying grub boot options etc, but it doesn’t seem to be helping. I am familiar with bash and Linux, but modifying low level settings and files is something I have avoided to date. This is also the first time I’m using an Nvidia product, and looks like its the last time. If I try Ctrl + Alt + F1, F2, … it just shows a black screen. I managed to boot from grub once, setting the priority to 3 and running xstart as shown in the following topic:
{[HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc) }
But it didn’t work after that. Please help. I don’t want to use Windows. Also, my laptop has HD520 integrated graphics, which I wouldn’t mind using for Linux, because I game on a separate Windows partition I have. However, I have no idea how to tell Linux to use the HD520 instead of the 920MX. There is an option in the laptop’s BIOS to disable the 920MX completely, but I would strongly not prefer doing that.

My laptop:
The forum thread I referred to:


Managed to boot again with the startx method, and enabled autologin. that seems to have fixed the issue. Leaving this thread for reference for any other poor soul with the same laptop in the same situation

Links can be used if you use codefence like this


On Lenovo systems you can - usually - choose which graphics to initialize first IGD or PEG.

If that is not an option - install using the open source option from the installers boot menu.

This works for me on a ThinkPad T550 (Intel 5500 - Nvidia 940M) and I realize the Yoga is different so this may not work for you.

1 Like

hi there. I managed to get it working (i dont know which GPU Linux is using but everything seems to work) after enabling auto log in. Regardless, thank you for replying. And i coincidentally came across your other posts on this website. you seem to be a great person who is really helpful. I am grateful for this community where I can connect with such individuals directly within an hour of encountering an issue. thanks again for responding

Great :slight_smile:

You can use inxi to display what graphics are working

inxi -G

I decided I had nothing to lose so I tried the open source driver option with a fresh install; opposite to what all the guides on the internet said, and it worked perfectly.

TLDR for reference:
Either install noveau drivers by the open source option
Or, alternatively, enable autologin

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.