Manjaro Gnome freezes random

Hello!! :grinning:
I think this is the last quirk to iron in my migration from KDE to Gnome on my little ThinkPad.

I’m experiencing some annoying little freezes randomly, I can’t move the cursor during 4 o 5 seconds, regardless of I use the mouse, trackpad, or pointer. After a few moments, everything continues normal.

In my previous KDE install, this issue didn’t happen.

This is the output to inxi -Fazy:

  Kernel: 6.7.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.7-x86_64
    root=UUID=60a9bdd0-965e-4b5a-80cd-98ea2c6bd70e rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro
    base: Arch Linux
  Type: Laptop System: LENOVO product: 20KFS0YM08 v: ThinkPad X280
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20KFS0YM08 v: SDK0J40697 WIN
    serial: <superuser required>
    part-nu: LENOVO_MT_20KF_BU_Think_FM_ThinkPad X280
    uuid: <superuser required> UEFI: LENOVO v: N20ET67W (1.52 )
    date: 11/15/2023
  ID-1: BAT0 charge: 35.7 Wh (79.3%) condition: 45.0/47.9 Wh (94.0%)
    volts: 12.2 min: 11.4 model: LGC 5B10W13920 type: Li-poly serial: <filter>
    status: not charging cycles: 196
  Info: model: Intel Core i3-8130U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1150 high: 3401 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3401 2: 400 3: 400 4: 400
    bogomips: 17605
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5917
    class-ID: 0300
  Device-2: Lite-On Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:3 chip-ID: 04ca:7070
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x226d built: 2015 res: 1920x1080
    dpi: 177 gamma: 1.2 size: 276x155mm (10.87x6.1") diag: 317mm (12.5")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    device-ID: 8086:5917 memory: 7.35 GiB unified: yes display-ID: :0.0
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  API: ALSA v: k6.7.7-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 3b:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp59s0 state: up mac: <filter>
  Info: services: httpd, NetworkManager, smbd, systemd-timesyncd,
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:2 chip-ID: 8087:0a2b
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Local Storage: total: 357.72 GiB used: 93.23 GiB (26.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB256HAHQ-000L7
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 1L2QEXD7 temp: 29.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Generic model: SD MMC size: 119.25 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s
    lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter> fw-rev: 1.00
    scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 69.87 GiB (29.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 4 GiB used: 35.8 MiB (0.9%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 43.0 C pch: 43.5 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0
  Memory: total: 8 GiB note: est. available: 7.52 GiB used: 4.74 GiB (63.0%)
  Processes: 272 Power: uptime: 18h 16m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 3 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 3 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1333 libs: 373 tools: gnome-software,pamac
    pm: flatpak pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash
    v: 5.2.26 running-in: gnome-terminal inxi: 3.3.33

I’ve searched in the forum, there are a lot of threads about freeze issues, but none like mine.

What info extra could apport?

Best regards!! :grinning:

1 Like

I’ve the same issue too.
Sometimes the screen freeze and cannot unfreeze just moving the mouse or typing on the keyboard. I need to restart the computer.
Anybody knows why?

In both cases it may be related to memory/swap.

So not much memory to begin with, and seems to be using over 60% during casual use.

Next to a pretty small SWAP

Assuming everything was working properly … this means a load of 11.5G memory would be the maximum.

Actual logs from during the occurrence would be more helpful.

But @Salvodif should probably produce something like system info, if not also start their own thread.


Hi!! :grinning:
Could you suggest what I command I should use to?

Best regards!!

You could increase the size of the swapfile.
Essentially just disable (sudo swapoff -a), delete and recreate it.
Here is an old walk-through (just note you want a larger size)

1 Like

Test your memory from the GRUB menu (Memtest). Have you recently installed new memory?

After some days of test, I confirm that the issue has gone away at least a 99,99%, thank you very much for your help!! :grinning:

I only have one question:
Previously, I have had enabled a 4GB swap file with this method:

fallocate -l 4G /swapfile
mkswap /swapfile
chmod u=rw,go= /swapfile
swapon /swapfile
bash -c "echo /swapfile none swap defaults 0 0 >> /etc/fstab"

Following you guide, now I have a 16 GB file swap:


However, I don’t understand it. Do this means that only 18% of this file is used and the real size of this file is 3 GB? Or the swap file has a real size of 17,2GB?

Best regards!! :grinning:

I do not know where that photo is from, but my guess is it is showing percent used.

As in your swapfile is 17.2GB and you are currently using 18% of it.

Hello!! :grinning:
From Disk Usage Analyzer, aka Baobab:

Best regards!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.