Manjaro Gnome - Change default terminal to terminator

I’m using Manjaro Gnome 21.1.6 and trying to change my default terminal from gnome-terminal to terminator. Tried many commands from the Internet, but none worked. the default apps do not have the option to change the terminal

How can I change my default terminal to terminator?

What command have not worked? Do you want to get fed those same commands here only to have to reply that you tried this and they do not work.

If your wish is to start a terminal with a shortcut simply add a shortcut to run it?
eg super + t starts terminator and/or on your preferred menu/overview/bar etc.

Played around with dconf, setting a different terminal does not change the default terminal, there are some articles about it when searching. No easy solution it seems.

edit: Re: Default terminal in GNOME 3 []

Well, I know there is a preset for gnome-terminal but what about other

Because we’re not designing a desktop for people who like to choose
their own terminal emulators.

After doing a lot of research, I couldn’t find a simple solution. so this is what I did. when I installed manjaro Ctrl + Alt + T was not opening the terminal and I had to create a custom shortcut to open the terminal.

I have updated that shortcut to open terminator instead of gnome-terminal, then I installed a package called FileManager-Actions from the manjaro package manager.

open file manager actions and click on define new action.

  • Add “Open in Terminator” in the Context label
  • Check “Display item in location context menu”
  • Switch to the “Command” tab and add /usr/bin/terminator in the path and --working-directory=%d/%b in parameters

When you open nautilus and right-click, you should see a FileManager-Actions > Open in Terminator option. If you still don’t see the option in nautilus. try running nautilus -q or rebooting.

now I didn’t like that FileManager-Actions submenu. To remove it, open FileManager-Actions again, go to Edit > Preferences, and uncheck “Create a root ‘FileManager-Actions’ menu” and that’s it

hope this helps :slight_smile:

1 Like

thanks for taking the time to answer. I figured it out after doing a bit of research.

1 Like

Great! Thanks for sharing your solution!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.