Manjaro Gnome 20.2 fails to add printer

Just did a fresh install of Manjaro Gnome. Everything works fine except I can’t get my Epson XP-620 network printer working. The add printer dialog sees the printer but when I try to add, it fails. This printer has always worked in any distro I’ve used, including Manjaro KDE. Thanks in advance for any help on this. Be safe, stay healthy, peace.


Maybe you need to update CUPS services:

@hadji457 have you had success getting your printer to install? I am having the same problem with a Brother printer.

Sorry for not responding sooner. I actually did a reinstall of Manjaro KDE, latest iso, and all is good again. So I am not sure if it is a Gnome specific issue or not. As far as Manjaro Gnome is concerned, I tried the suggested fixes to no avail. I did want to give Gnome as shot, but not being able to setup my printer was a deal breaker for me. I may try again next major update.

Hi, I had to install an additional package “system-config-printer” to get the printer installed through Gnome settings.

If cups is installed correctly then you should always be able to install via localhost:631 in your web browser.

1 Like

Thanks. That’s good to know. I still want to give Manjaro Gnome a go.

Reinstalled Manjaro Gnome. Still had issue with printer setup. Installed “system-config-printer” and was able to setup my printer without issue. Thanks for the tip.
Why would this package not be part of the install image by default? Just curious.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.