Manjaro gives black screen

Hello guys, I just installed Manjaro i3 community edition, but the problem is it gives me black screen all the time. I mounted the root in a live environment and opened grub.cfg and /etc/default/grub, then I removed ‘quiet’ from linux line. It worked once then it back again, I think when I unplugged the flash usb.
My laptop is dell Inspiron 5567 with amd radeon r7.

if it’s anything like the sway install, the new installer leaves crap behind in the login manager.
check /etc/lightdm/config(?)
look for the autologin=
if it says oem change it to your user name.
your also going to need to check the session, make sure its set to i3 & not the installer.
you can do it in another device or by booting & switching to another tty(ctrl+alt+f2) holpe you know your cli.

cd /etc/lightdm
sudo nano config

i can’t be accurate because sway boots differently, i had to change greetd.

I did this but nothing changes. I get the same black screen.

Okay, I found this and it worked for starting the X session, but every time I have to boot to tty1 console and do:

systemctl start lightdm.service

Is there a solution to make this permanent?


systemctl start lightdm.service

followed by

systemctl enable lightdm.service

I did that, but nothing changes. So, after I started the X session using systemctl start lightdm.service, I ran systemctl status lightdm.service and this is what I got:

lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2021-07-07 04:59:48 EET; 18s ago
Docs: man:lightdm(1)
Main PID: 752 (lightdm)
Tasks: 20 (limit: 9407)
Memory: 185.5M
CPU: 748ms
CGroup: /system.slice/lightdm.service
├─752 /usr/bin/lightdm
└─763 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
jul 07 04:59:48 manjaro systemd[1]: Starting Light Display Manager…
jul 07 04:59:48 manjaro systemd[1]: Started Light Display Manager.
jul 07 04:59:51 manjaro lightdm[791]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=969) by (uid=0)
jul 07 04:59:54 manjaro lightdm[841]: gkr-pam: unable to locate daemon control file
jul 07 04:59:54 manjaro lightdm[841]: gkr-pam: stashed password to try later in open session
jul 07 04:59:54 manjaro lightdm[841]: pam_systemd_home(lightdm:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
jul 07 04:59:54 manjaro lightdm[841]: pam_unix(lightdm:session): session opened for user logan(uid=1000) by (uid=0)
jul 07 04:59:54 manjaro lightdm[841]: pam_env(lightdm:session): deprecated reading of user environment enabled
jul 07 04:59:54 manjaro lightdm[841]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring

In my opinion the output shows no abnormalities.

Edit: But if you are on the i3 surface:
Switch to bmenu with mod+CTRL+b
Push 7, then 4, then 9, then 2
Enter your Password
Push 1 to make lightdm default and enter.
Restart and report what happend.

When I hit 1 in the last step, It does nothing. How can I make this manually?

I’m not longer using i3 and report from my notes at the time.
But I think if nothing happens in the last step, then there may be nothing to install. Which could mean that lightdm is not the problem at all.

I’ll keep opening using tty & systemctl till I find a solution, I think I can live with it :grinning_face_with_smiling_eyes:
Anyway, thank you man, much appreciated.