Manjaro getting No sound

When I first installed Manjaro then there was sound but the full volume was not loud enough. After some updates I am not hearing any sound att all.

inxi -Fazy
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: QUANTA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401

I have uninstalled pulseaudio and installed pipewire but still not solved.

sudo systemctl status pipewire.socket                                                                             1 ✘ 
[sudo] password for neel: 
Unit pipewire.socket could not be found.
    ~  systemctl --user status pipewire.socket                                                                           4 ✘ 
● pipewire.socket - PipeWire Multimedia System Socket
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; preset: enabled)
     Active: active (running) since Sun 2022-09-04 18:51:37 CEST; 16min ago
      Until: Sun 2022-09-04 18:51:37 CEST; 16min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1001/pipewire-0 (Stream)
     CGroup: /user.slice/user-1001.slice/user@1001.service/app.slice/pipewire.socket

Sep 04 18:51:37 laptop systemd[694]: Listening on PipeWire Multimedia System Socket.
    ~  systemctl --user status pipewire.service                                                                            ✔ 
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: enabled)
     Active: active (running) since Sun 2022-09-04 18:51:38 CEST; 16min ago
TriggeredBy: ● pipewire.socket
   Main PID: 907 (pipewire)
      Tasks: 2 (limit: 18915)
     Memory: 10.4M
        CPU: 2.298s
     CGroup: /user.slice/user-1001.slice/user@1001.service/session.slice/pipewire.service
             └─907 /usr/bin/pipewire

Sep 04 18:51:38 laptop systemd[694]: Started PipeWire Multimedia Service.
    ~  systemctl --user status pulseaudio.service                                                                          ✔ 
Unit pulseaudio.service could not be found.
    ~  systemctl --user status pulseaudio.socket                                                                         4 ✘ 
Unit pulseaudio.socket could not be found.
    ~  sudo systemctl status pulseaudio.socket                                                                           4 ✘ 
Unit pulseaudio.socket could not be found.
    ~  sudo systemctl status pulseaudio.service                                                                          4 ✘ 
Unit pulseaudio.service could not be found.
$ pactl info                                                                                                        1 ✘ 
Server String: /run/user/1001/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 434
Tile Size: 65472
User Name: neel
Host Name: sunanda-laptop
Server Name: PulseAudio (on PipeWire 0.3.56)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink
Default Source: alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source
Cookie: ed04:6ee7

After failing wwith pipewire I have uninstalled it and installed manjaro-pulse

sudo pacman -Rdd manjaro-pipewire pipewire-alsa pipewire-pulse pipewire-zeroconf pipewire-media-session
sudo pacman -S majnaro-pulse

But due to plasma shell’s dependence on libpipewire-0.3.so.0 I had to reinstall only the pipewire package.

It doesn’t make anything better. No sound with pulse also.

post system info:
inxi -Faz
try with different kernels: 5.10 lts and the 5.19.1-3

Full output

$ inxi -Fazy                                                                                                          ✔ 
System:
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=2b597c72-8510-434e-a7bd-ed1375d5ac95 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: HKD-WXX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: HKD-WXX-PCB v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.20 date: 04/19/2022
Battery:
  ID-1: BAT1 charge: 57.5 Wh (97.0%) condition: 59.3/59.7 Wh (99.4%)
    volts: 13.2 min: 11.6 model: NVT HB5781P1EEW-31T type: Li-ion
    serial: <filter> status: charging cycles: 17
CPU:
  Info: model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 built: 2020 process: Intel 10nm
    family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 704 high: 1082 min/max: 400/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 625 2: 617 3: 668 4: 529
    5: 477 6: 688 7: 950 8: 1082 bogomips: 52856
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: QUANTA
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Luxvisions Innotech USB Camera type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 30c9:0041 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2520x1680 s-dpi: 96 s-size: 666x444mm (26.22x17.48")
    s-diag: 800mm (31.51")
  Monitor-1: eDP-1 model-id: CSO 0x140d serial: <filter> built: 2021
    res: 2520x1680 dpi: 213 gamma: 1.2 size: 300x200mm (11.81x7.87")
    diag: 361mm (14.2") ratio: 3:2 modes: 2520x1680
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.6
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: QUANTA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 42.93 GiB (4.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: PCIe-8 SSD 1TB size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: YM00D213 temp: 29.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 440 GiB size: 432.02 GiB (98.19%) used: 42.89 GiB (9.9%)
    fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 200 MiB size: 196 MiB (98.00%) used: 44.1 MiB
    (22.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 251 Uptime: 1d 10h 23m wakeups: 475 Memory: 15.41 GiB used: 2.8
  GiB (18.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pm: pacman pkgs: 1589
  libs: 357 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21

Updated to 5.19.1-3-MANJARO. Still same.

well you have a huawei and you have to wait until its fixed upstream according to arch wiki … however there are some workaraunds to make the audio work… first you have to have installed sof-firmware:
pamac install sof-firmware
then creat this file:
kate /etc/modprobe.d/audio.conf
and put there this line:
options snd-intel-dspcfg dsp_driver=3
which unfortunately renders the microphones unusable.
then run this:
sudo mkinitcpio -P
reboot and test

But it was usable when I first installed. However it was not perfect. Full volume was not achievable. It broke after some updates.

I see that sof-firmware-2.2-1 is already installed in my system.

But /etc/modprobe.d/audio.conf doesn’t exist. Even /etc/modprobe.d is an empty directory.

But there are many modules with sof substrting loaded into the kernel.

$ lsmod | grep sof                                                                                                    ✔ 
snd_sof_probes         24576  0
snd_sof_pci_intel_tgl    16384  0
snd_sof_intel_hda_common   151552  1 snd_sof_pci_intel_tgl
soundwire_intel        53248  1 snd_sof_intel_hda_common
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof_pci            24576  2 snd_sof_intel_hda_common,snd_sof_pci_intel_tgl
snd_sof_xtensa_dsp     20480  1 snd_sof_intel_hda_common
snd_sof               262144  3 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_probes
snd_sof_utils          20480  1 snd_sof
snd_soc_hdac_hda       28672  1 snd_sof_intel_hda_common
snd_hda_ext_core       36864  4 snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_sof_intel_hda
snd_soc_acpi_intel_match    69632  2 snd_sof_intel_hda_common,snd_sof_pci_intel_tgl
snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_sof_intel_hda_common
snd_soc_core          393216  8 soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_sof_probes,snd_soc_dmic,snd_soc_skl_hda_dsp
snd_compress           28672  2 snd_soc_core,snd_sof_probes
snd_intel_dspcfg       36864  2 snd_hda_intel,snd_sof_intel_hda_common
snd_intel_sdw_acpi     20480  2 snd_sof_intel_hda_common,snd_intel_dspcfg
snd_hda_core          118784  11 snd_hda_codec_generic,snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_intel_hda_dsp_common,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_sof_intel_hda
snd_pcm               172032  12 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_compress,snd_soc_core,snd_sof_utils,snd_hda_core,snd_pcm_dmaengine
snd                   126976  25 snd_ctl_led,snd_hda_codec_generic,snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_sof,snd_timer,snd_soc_hdac_hdmi,snd_compress,snd_soc_core,snd_pcm

yes theres a lot of sof audio related modules…
thats why you should create the file to make the audio working on huawei according to arch wiki …
since youre using pulse audio run this command:

sudo pactl set-sink-port alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink '[Out] Headphones'

and test - if it worked you have to use it at every boot according to the wiki …

I suspect you are referring to suggestion from Huawei MateBook 14s - ArchWiki that appears to have misread issue report cited as source – [BUG] Huawei Matebook 14s headphone / speaker problem (CX8070 codec) · Issue #3350 · thesofproject/linux · GitHub
I can see no mention of using option 3, only that option 1 does not work

$ modinfo snd-intel-dspcfg | grep parm
parm:           dsp_driver:Force the DSP driver for Intel DSP (0=auto, 1=legacy, 2=SST, 3=SOF) (int)

Option 3 is to force use of SOF driver ( sof-audio-pci-intel-tgl)

Option 1 to force use of legacy driver (snd_hda_intel) would disable internal dmic

sudo tee /etc/modprobe.d/audio.conf <<< 'options snd-intel-dspcfg dsp_driver=1

mkinitcpio or GRUB update is only needed if modprobe option is added to /etc/default/grub
modprobe options added to /etc/modprobe.d/ only need a reboot

yes thats what im reffering from …
the arch wiki mentioned adding the option 3…
in the github link the last post mentioned a ‘solution’ to run the sudo pactl set-sink-port ... command, but it only works with pulse

and you have to run mkinitcpio after you adding options for specifice modules, i tested it myself - was adding options to i915 and they were not applied without me running mkinitcpio …

Tried. Didn’t work.

$ sudo pactl set-sink-port alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink '[Out] Headphones'
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

sof-audio-pci-intel-tgl not in the repo. How do I install that ? and my /etc/modprobe.d/ is empty. There is nothing inside.

PulseAudio command pactl would not work with sudo

Final comment in sofproject issue report advises iro pactl command (without sudo):

Unfortunately, I couldn’t get that to work with PipeWire, because it doesn’t allow applications to use that sink (maybe because it shows up as Unplugged?)

Command might work if the jack misdetection as unplugged is resolved

inxi data in post #3 shows system already has driver: sof-audio-pci-intel-tgl

my /etc/modprobe.d/ is empty. There is nothing inside.

Please get more information about ALSA for default state (no modprobe options) with kernel v5.19

sudo alsa-info.sh --upload
$ sudo alsa-info.sh --upload  
cat: '/sys/module/snd_soc_skl_hda_dsp/parameters/*': No such file or directory
/usr/bin/alsa-info.sh: line 661: tree: command not found
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://alsa-project.org/db/?f=6e32ebab042a434bdff67c17f6461bc2d78890d7
Please inform the person helping you.

Also, whenever I play something in youtube, I hear very low volume noise which gets little louder as I move my finger over the touchpad.

did you run this command without sudo:

pactl set-sink-port alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink '[Out] Headphones'

did it work?
did you tried also this command:

then reboot and test if it helped

It worked once. But most of the time it doesn’t. In the KDE Audio settings I see that the playback device is on Port Headphone. I change that to Speaker and try playing youtube or click Test. It only worked once.

There is nothing on /etc/modprobe.d/audio.conf should I create an empty file ?

well if the command didnt create it, so create it manually:
kate /etc/modprobe.d/audio.conf
put there this:
snd-intel-dspcfg.dsp_driver=1
reboot