Manjaro froze completely - Now grub refuses to boot, stuck on Blinking cursor

Hi All,

I was using Manjaro and multitasking, I turned on Minecraft and the entire OS froze. I did not realize “raise the elephant” was a thing at the time and so I held down the power button until the PC turned off. On reboot after the BIOS screen I am greeted with a blinking _ cursor. tty does not work and at that point I reboot it.
I have managed to boot up a bootable USB and using the grub command line I can get it to boot with the following commands:

grub> set root=(hd4,2)
grub> linux /boot/vmlinuz-5.10-x86_64 root=/dev/nvme0n1p2
grub> initrd /boot/initramfs-5.10-x86_64-fallback.img
grub> boot

it is important to note if i use a non failback kernel (initramfs-5.10-x86_64.img) It will hang completely.

I originally thought there was a KERNEL issue and so i uninstalled 5.15. I will go back to it eventually now that I know with either kernel (5.10 or 5.15) it will hang if i do not use the failback.

I had this happen before and I am not sure how I got it to work.

I would like to repair my grub boot. I have tried the directions below:
and I had no luck with them. Please let me know where to go from here. I really appreciate the support for this OS and it upsets me that I can’t get this to work.

also when I run update-grub this is what I get:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your
Found Pop!_OS 20.04 LTS (20.04) on /dev/nvme0n1p4
Found Windows 10 on /dev/sdb1
Found Windows 10 on /dev/sdb2
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Here is the output of grub-install:

[xxx]# grub-install /dev/nvme0n1
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.

Please dont mind my disarray of OS installs. I assure you Manjaro is my laptop and desktop daily driver.

1 Like

This leads to a row of open questions:

  • On which drive should manjaro be found ?
    • /dev/sdc1
    • /dev/nvme0n1p ?
  • Grub complains about nvme0n1 not having …
  • What is the layout on /dev/nvme0n1
  • Do you normally boot with UEFI-boot ?
    • Did you boot your live manjaro as UEFI-boot or BIOS-boot when trying to install GRUB ?
    • Did you chroot ?


Thank you for your quick response!

Manjaro is on nvme0n1p2. /dev/sdc1 is the USB I made to boot into the grub command line.

[xxx]$ lsblk
loop0       7:0    0  99.4M  1 loop /var/lib/snapd/snap/core/11798
loop1       7:1    0  55.5M  1 loop /var/lib/snapd/snap/core18/2246
loop2       7:2    0  65.2M  1 loop /var/lib/snapd/snap/gtk-common-themes/1519
loop3       7:3    0 164.8M  1 loop /var/lib/snapd/snap/gnome-3-28-1804/161
loop4       7:4    0  55.5M  1 loop /var/lib/snapd/snap/core18/2253
loop5       7:5    0   289M  1 loop /var/lib/snapd/snap/solus-runtime-gaming/12
loop6       7:6    0   3.1M  1 loop /var/lib/snapd/snap/linux-steam-integration/12
loop7       7:7    0     4K  1 loop /var/lib/snapd/snap/bare/5
loop8       7:8    0  99.4M  1 loop /var/lib/snapd/snap/core/11993
sda         8:0    0 931.5G  0 disk 
├─sda1      8:1    0     1K  0 part 
└─sda5      8:5    0 931.5G  0 part 
sdb         8:16   0 931.5G  0 disk 
├─sdb1      8:17   0   500M  0 part 
├─sdb2      8:18   0 930.5G  0 part 
└─sdb3      8:19   0   532M  0 part 
nvme0n1   259:0    0   1.8T  0 disk 
│         259:1    0     8M  0 part 
│         259:2    0   484G  0 part /run/timeshift/backup
│                                   /
│         259:3    0    16G  0 part 
          259:5    0     4G  0 part [SWAP]

Here is the output of fdisk -l /dev/nvme0n1

> [xxx ~]$ sudo fdisk -l /dev/nvme0n1
> Disk /dev/nvme0n1: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
> Disk model: PCIe SSD                                
> Units: sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> Disklabel type: gpt
> Disk identifier: A6BECC41-6270-204E-A7EF-986FE5C583B9
> Device              Start        End    Sectors  Size Type
> /dev/nvme0n1p1       2048      18431      16384    8M Linux filesystem
> /dev/nvme0n1p2      18432 1015039999 1015021568  484G Linux filesystem
> /dev/nvme0n1p3 1015040000 1048594431   33554432   16G Linux swap
> /dev/nvme0n1p5 2071914496 2080303101    8388606    4G Linux swap

I can confirm I boot from BIOS. My /boot is located on the same partition as /.

[xxx]$ ls /sys/firmware/efi
ls: cannot access '/sys/firmware/efi': No such file or directory
[aww@aw-stormtrooper2 ~]$

But you do have a gpt. Then you have special needs for grub. I think there is a arch-wiki on using BIOS and GPT together with grub.

There might be described what you have to do to reinstall grub in your case.

I did use BIOS and GPT (years ago) but now have UEFI and gpt, so this is not directly comparable.

1 Like

is it difficult to switch from one to the other? I should be using UEFI as it is newer.

Hi Just a update!!

I went into gparted and went to make a backup of my FS so that i could prepare to move around partitions to build a EFI drive. when i pressed refresh in gparted the program hung and threw an exit code and closed. On reboot I could not longer see my nvme drive. I opened and reseated the drive on my PC. On reboot it magically worked as intended!!! The drive is failing or failed IMO. It is a Inland nvme drive as well!!!

I am backing up and ordering a new drive as we speak.

Thank you @andreas85 for your help!!!

1 Like

is there a way to copy all of my package names so that after the new drive i can reinstall all of them easily

1 Like

Next time before you install anything learn the requirements for UEFI boot on one hand and BIOS (legacy) boot on the other hand. They usually require the right partition scheme. BIOS and gpt can be combined but you need to understand the special BIOS boot partition requirement if you want to use grub to boot. You will easily get in trouble if you mix these techniques. This is all pretty good described in wikipedia, Archlinux wiki and Manjaro wiki but you need to spend some time to get familar with this. A search engine of your choice is your friend.


Thanks Wollie, I am going to go over it now. I was following the guide from red hat to transfer from bios to UEFI but when i went to backup my drives it stopped running.

Thanks freggel.doe, I spoke too soon and I did find the same article and did said commands.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.