Manjaro fresh install black screen on nvme ssd

I downloaded the latest version of manjaro xfce on June 25 and I successfully installed it on my laptop SSD.

Today I just built a pc with a Intel i3-10320 10 gen cpu and asus prime b560m-a motherboard and western digital black nvme m2 ssd but once i select install with proprietary drivers or instal with open source drivers I get a black screen and my monitors have no display.

I have tried to disable fast boot in bios and disabled the sata controllers and still nothing. I was able to install windows 10 with no problem.

Is there any help I can get? I have tried searching up a solution on here but can’t seem to find a fix. Does this mean manjaro is not compatible with my hardware? Thank you.

Welcome here, @Saberzero,

boot into the live ISO, open a terminal and enter

inxi -Fazy

and post the output here.

I only have the screen when you boot into the USB and the options to change the timezone, keyboard language, language, boot with open source drivers, boot with proprietary drivers, boot with open source drivers.

When I click either boot options, the screen posts 3 mce hardware errors:

then the screen stays black and monitor gives no response.

so I added i915.modeset=0 , it now goes past the error part and prints out that it is starting everything but freezes at [ OK ] Reached target Graphical Interface. Will this not work with an integrated intel UHD Graphics 630?

Unlikely, but I would also try the xfce minimal Linux54 LTS.

same thing as with the regular one, it gives the mce error codes then black screen, or if i add i915.modeset = 0 and nomodeset to set params it hangs on [ OK ] Reached target Graphical Interface

i guess i will try with another usb and if not, it seems manjaro is not compatible with my motherboard and cpu combination.

so there was no bad sectors on my USB after checking and installation is still hanging up on

[OK] Finished Initalize Pacman keyring
[OK] Reached target Multi-User System
[OK] Reached target Graphcial Interface.

this seems like an intel problem then and i will not be able to use manjaro on my new PC

I added acpi=off nomodeset i915.modeset=0 to kernelparams by pressing E on grub and was able to get to a terminal,

This is what comes up when I run the command

The begin of the inxi output is missing, try to share this as well.

What we can see is that the graphic driver was not installed, have you tried to install with non-proprietary (free) drivers?

I’m not convinced by the kernel parameters you tried to add…

1 Like

I tried inxi -Fazy but i can’t scroll up in tty

I tried with open source and got the same problem as with proprietary, it ends with this.

I added

acpi =off i915.modeset=0 nomodeset=0

to key params and I’m trying to use integrated Intel graphics, my bios is also updated to the newest version

well I tested it out with an evga gtx 960 in my pc and it worked, no need to change params… seems it’s the iGPU that is the problem…

used the default bios settings as well, seems like a discrete gpu is required with the b560 motherboard and 10th gen cpu

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.