Manjaro freezing on laptop while using battery (on several kernels)

I’ve been using Manjaro for around 3 months now, just coming out of Windows for the first time ever, but my computer keeps freezing when running on battery. I’ve tried several kernels, but the problem persists.

I also can’t seem to get the soft restart (alt + prt sc + reisub) to work, so I have to constantly press the power button to shutdown and restart.

Some of the suggestions I found through searches are just too technical for my current knowledge, can you please help?

Thank you.

Apparently there are two ways of enabling alt+SysRq+ both are covered in a couple of old forum posts:


Personally I used the instructions in the second link I posted.

1 Like

Thank you so much, I managed to get the alt + prt scr + reisuo command to work with the first link you sent me!
As for the main problem regarding constant system freezes while using battery only, can anyone help?

Can you post the output of inxi -Fz so we get some system info.

Sounds like a battery issue. Is it working on Win? Just as an example; this totally knackered battery still looks ‘ok’ but the lap crashes after 2min:

$ inxi -B
  ID-1: BAT0 charge: 39.1 Wh (96.1%) condition: 40.7/48.6 Wh (83.8%)
1 Like

Here is the system info:

    ~  inxi -Fz                                                                                                                               ✔ 
  Kernel: 5.14.21-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.23.4
    Distro: Manjaro Linux
  Type: Laptop System: HP product: HP Laptop 15s-fq1xxx v: N/A
    serial: <superuser required>
  Mobo: HP model: 86C9 v: 56.33 serial: <superuser required> UEFI: AMI
    v: F.18 date: 04/16/2021
  ID-1: BAT0 charge: 21.4 Wh (59.8%) condition: 35.8/35.8 Wh (100.0%)
    volts: 11.1 min: 11.3
  Info: dual core model: Intel Core i3-1005G1 bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 1300 min/max: 400/3400 cores: 1: 1301 2: 1300 3: 1300
    4: 1301
  Device-1: Intel Iris Plus Graphics G1 driver: i915 v: kernel
  Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org driver: loaded: modesetting
    resolution: 1366x768~60Hz
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Ice Lake-LP Smart Sound Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.21-2-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce
  IF: wlo1 state: up mac: <filter>
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  Local Storage: total: 238.47 GiB used: 157.63 GiB (66.1%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: N/A size: 238.47 GiB
  ID-1: / size: 70.28 GiB used: 28.22 GiB (40.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 511 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 157.54 GiB used: 129.41 GiB (82.1%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: partition size: 4.88 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p4
  System Temperatures: cpu: 60.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 224 Uptime: 0m Memory: 7.46 GiB used: 2.35 GiB (31.5%)
  Shell: Zsh inxi: 3.3.11

Apparently the battery is fine.

Yes, looks brand new, however:

volts: 11.1 min: 11.3

is odd. Also, why is the charge at 59% if there’s no other OS and manjaro crashes immediately when on battery; shouldn’t the battery then be at around 97-100%? Does it charge ok?

don’t know if this will work :crossed_fingers:

make a backup:

sudo cp /etc/acpi/ /etc/acpi/

in /etc/acpi/ change BAT0 to BAT1 as root


I tried this option, but still no luck. It does seem to freeze a bit less often, once every hour or so.
Also, as I stated before, the soft restart option doesn’t work when the system freezes.
Any other options that might help with this issue?

switch to lts kernel:

That was the kernel I first installed, the freezes happened there as well, that’s why I ended up updating to 5.13.19-2 and then to 5.14.21-2. I even downgraded to 5.4.169-1, but the problem still occurred