Manjaro fails to configure correct pinentry for KDE Plasma

On KDE plasma, Kleopatra password pop up (pinentry) appears with inconsistent theme (gtk2)

The problem seems coming from an incorrect configuration which favors GTK version over Qt one in file usr/bin/pinentry


# user-defined pre-exec hook
test -r "${XDG_CONFIG_HOME:-$HOME/.config}"/pinentry/preexec &&
    . "${XDG_CONFIG_HOME:-$HOME/.config}"/pinentry/preexec

# site-defined pre-exec hook
test -r /etc/pinentry/preexec &&
    . /etc/pinentry/preexec

test -e /usr/lib/ &&
    exec /usr/bin/pinentry-gtk-2 "$@"

exec /usr/bin/pinentry-curses "$@"

After raising the problem to Kleopatra team 434301 ā€“ Inconsistent theme it seems the problem should be fixed by distribution team by preferring Qt pop up over GTK one.
For now the easy fix is to add manually a file ~/.gnupg/gpg-agent.conf containing pinentry-program /usr/bin/pinentry-qt

When you installed pinentry what optional backend have you chose ?


1 Like

I never installed it manually it was there from start, and I have all of theme installed. And those optional packages have no role in setting which pop up to use because pinentry package installs all these files :

So the real problem comes from the content of /usr/bin/pinentry

Have you checked the /etc/pinentry/preexec file and eventually uncomment the qt related line?

1 Like

Yeah un-commenting the last line in /etc/pinentry/preexec also solves the problem, but Iā€™m not sure if checking for a specific qt library is the solution, because in few months/years Qt apps can jump to higher qt library version. Iā€™m not talking about how to solve the problem manually, but how to fix it for a clean Manjaro distribution without requiring any user modification.

AFAIK is a package inherited from Arch Linux, so probably it would require an overlay ā€¦ Someone from Manjaro Team could probably have a look. Will notify them.

1 Like

Thanks :slight_smile: