Manjaro failed to load the kernel modules

When attempting to boot into manjaro today, I am told that manjaro failed to load the kernel modules. After some reading I followed the advice an booted into a live-manjaro, and executed
sudo manjaro-chroot -a

grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]

I then chrooted into manjaro following thes instructions: [HowTo] Chroot from or into any Linux distribution

But now I’m lost. Can you please help me to find and fix the issue? The following information might be helpful:

LANG=C sudo parted -l
|-nvme0n1p2                           66.4M    31% /boot/efi
`-nvme0n1p5                          200.4G    80% /
Model: Verbatim STORE N GO (scsi)
Disk /dev/sda: 7744MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3530MB  3534MB  4194kB  primary               esp

Model: Force MP510 (nvme)
Disk /dev/nvme0n1: 1920GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  556MB   555MB   ntfs         Basic data partition          hidden, diag
 2      556MB   661MB   105MB   fat32        EFI system partition          boot, esp
 3      661MB   677MB   16.8MB               Microsoft reserved partition  msftres
 4      677MB   461GB   460GB   ntfs         Basic data partition          msftdata
 5      461GB   1920GB  1460GB  ext4         root

The nvme0n1p5 is my manjaro installation.

(base) [manjaro /]# mhwd-kernel -li
Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515

first rerun update:
pacman-mirrors --fasttrack 5 && pacman -Syyu
are you running nvidia?

Hell again, brahma.
Update the live-distro or the original installation?

Yes, I run nvidia. You&I had a good time about a month ago, finding out which linux-kernel and which nvidia-drivers work on my hardware …

haha … no you run in from chroot - chroot, then run the update command …
probably the failed kernel modules are nvidia again …

I entered the orig. Installation and typed in the commands. Pacman suggests to update the nvidia-drivers, but I am reluctant to do so. Still: not updating doesnt solve the problem neither :slight_smile:

yes you had to downgrade the nvidia, because nothing we tried worked … so did you update them with the latest update that was few days ago?

They were set to “ignore” in the software-manager (gui). But it happened before that they got updated anyway, so this was the first thing I checked today. The packages have the correct version.

So it must be related to another updated package.

you had kernel blacklisted too … that could be related … since the issue is around month ago, lets try to update the nvidia+kernel to the latest, because you cannot function like that …
so just rerun the update so that it updates the kernel + nvidia …

I am now running linux6.0.0.rc4-1 kernel, together with nvidia driver 2021.11.04 - and I’m back in the game.

Thank you very much, brahma. I very much appreciate that you seem to be online in this forum for weeks, just waiting for me to post my next manjaro’s issue.

glad that it worked… and the 6.0 could be unstable, maybe it would be better to switch to the 5.19:
sudo mhwd-kernel -i linux519

I believe we tried&error-ed 5.19 before… but I will give it another shot.

However, giving the amount of troubles I had during the last months with kernels and drivers, the word “stable” does not mean to me what it once did :wink:

haha thats true … if you so far didnt noticed any troubles on the 6.0 so keep using it, if you do noticed, then try the 5.19 …

5.19 leaves me with a blinking cursor… :frowning: so we hope for the best with the 6.0 version.