Manjaro Failed to create partition

I had deleted my old manjaro and tried to reinstall it but everytime it gives the same error as:

Failed to add partition 'New Partition' to device '/dev/nvme0n1'.
Command: sfdisk --force --append /dev/nvme0n1.

I have followed this guide and did everything: [root tip] Dual boot Manjaro and Windows

[manjaro@manjaro ~]$ inxi -Fza
System:    Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro 
           misolabel=MANJARO_KDE_202 quiet systemd.show_status=1 apparmor=1 security=apparmor driver=nonfree nouveau.modeset=0 
           i915.modeset=1 radeon.modeset=1 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505DT.315 date: 09/22/2020 
Battery:   ID-1: BAT0 charge: 36.0 Wh condition: 37.1/48.1 Wh (77%) volts: 12.8/11.7 model: FX50442 type: Li-ion serial: N/A 
           status: Charging 
CPU:       Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen+ 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33550 
           Speed: 1248 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1456 2: 1229 3: 1225 4: 1227 5: 1224 
           6: 1223 7: 1223 8: 1224 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 455.45.01 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f91 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 05:00.0 
           chip ID: 1002:15d8 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 3-1:2 chip ID: 13d3:56a2 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati,nvidia unloaded: modesetting,nouveau 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) v: 4.6 Mesa 20.2.3 
           direct render: Yes 
Audio:     Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10fa 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave driver: rtw_8822ce v: N/A 
           modules: rtw88_8822ce port: d000 bus ID: 04:00.0 chip ID: 10ec:c822 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 29.25 GiB used: 806.6 MiB (2.7%) 
           ID-1: /dev/sda type: USB vendor: SanDisk model: Cruzer Blade size: 29.25 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: N/A size: 5.74 GiB used: 806.6 MiB (13.7%) fs: overlay source: ERR-102 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 47.9 C mobo: N/A gpu: amdgpu temp: 47.0 C 
           Fan Speeds (RPM): cpu: 2400 
Info:      Processes: 260 Uptime: 12m Memory: 7.65 GiB used: 1.49 GiB (19.5%) Init: systemd v: 246 Compilers: gcc: N/A 
           Packages: pacman: 1229 lib: 333 flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.08
[manjaro@manjaro ~]$ sudo parted -l
Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sda: 31.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3089MB  3093MB  4194kB  primary               esp
[manjaro@manjaro ~]$ sudo efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0000,0003,0004,0002,0001
Boot0000* Windows Boot Manager  HD(1,GPT,c1cdce95-cfb4-44cb-8010-3813b14bc8dd,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* Manjaro       VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* UEFI: SanDisk PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(1,0)/CDROM(1,0x5c0c4c,0x8000)..BO
Boot0004* UEFI: SanDisk, Partition 2    PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(1,0)/HD(2,MBR,0x0,0x5c0c4c,0x2000)..BO
[manjaro@manjaro ~]$ test -d /sys/firmware/efi && echo efi || echo bios

Note: Also tried KDE Partition manager but it hangs and fails to format Sometimes.

Hi @garvitjoshi9,
I’m in no way an expert, so don’t take what I’m saying as expert advice or knowledge or anything.

However, from what I can see there is only one had drive in the machine. No SSD (as the /dev/nvme0n1 would suggest.

So my opinion is that the SSD is either not present or faulty.

As the output from efibootmgr indicates a windows installation you are advised to check your firmware settings.

Being able to install Ubuntu does not mean being able to install Manjaro.

If you have installed Ubuntu using LVM you will - usually - need to remove the LVM volume(s) before you can install Manjaro using the graphical Calamares installer.

You say you followed the guide - but did you set the disk device to AHCI and disabled RST/Optane?

Failing to apply these changes often results in the device not being visible to the Manjaro system.

1 Like

Sorry Correct me if i am wrong, I am Using AMD And it should not have RST OPTANE
These are my BIOS Settings:

Internal Pointing Device: Enabled
Wake on Lid Open: Enabled
SVN Mode: Disabled
UMA Frame Buffer Size: 128M
SMART Self Test: On
Network stack : Disabled
Legacy USB Support: Enabled
USB Mass storage Driver Support: Enabled
SATA Mode Selection: AHCI
NVMe Config: BUS:3 Dev:0 Func: 0
Nvme Size:512.1 GB
Secure Boot Control: Disabled
I/O Interface Security: 
Wireless Network Interface:UNLOCK
LAN Network Interface UNLOCK
HD AUDIO Interface: Unlock
USB Interface Security:
USB Interface: UnLoCk
External Ports: Unlock
Bluetooth: UNLOCk

Hey Sir,
I just flashed BIOS again. Now installer is working fine.
And how can I remove ubuntu Boot0001 from efibootmgr?

$ efibootmgr -h

If I remember correct

# efibootmgr -b XXXX -B
1 Like

As your disk is MBR parted it can carry only 4 primary partitions. In your posts you did not share full output of

sudo parted -l

so it’s hard to say if that’s maybe the reason. If yes, you could make an extended partition and transfer at least one partition inside it. Then you can prepare many further logical partitions inside of the extended partition which also could be / and /home of your Manjaro system for example.

Found a Solution:

  1. While using a a live USB boot into manjaro with Open Source Software.
  2. DO not Start Calamares
  3. Open KDE Partition Manager.
  4. Now KDE Partition Manager will work fine and Format the SSD or HDD with ext4 you want to install Manjaro on
  5. After success, reboot and then Again go into live USB with Open Source or Propitiatory Drivers, and it will work fine.
    Thanks All for Helping me you all guys.
    I was using Ubuntu Before Manjaro, I never regret moving to this distro, and I have even uninstalled windows 10 now.
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.