Manjaro failed to boot in UEFI mode

But 512MiB are still probably a recommendation and not a requirement. I have dual boot with Windows and my 260MiB ESP partition has only 30MiB occuppied.

1 Like

it does work:

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        96M   58M   39M  60% /boot/efi

until it doesn’t… :smiling_imp:

1 Like

Yes, I know. But what I mean, is that in general, there is no requirement on ESP partition to be 512MiB. Maybe for some faulty motherboards it’s that way, but I wouldn’t say that it’s not working due to the partition size, as it were an absolute truth

1 Like

Yes, you’re absoluteness correct, but we’re trying to help an end-user here and protect him/her from future calamities…

:stuck_out_tongue_winking_eye: :crazy_face:

1 Like

I agree with you, and usually I try to help people understand the better options. What I’m arguing here is the language. From the first moment the OP have been told that ESP need to be 512MiB, even if his was already 300MiB (that I consider more than generous).
One thing is educate people and other imposing own opinions on the matter.

Maybe in the end, because of a faulty UEFI, the ESP in that case needs to be 512MiB, but then you can say something like “Hey, sometimes UEFI needs a 521MiB. Can you try that?”

Anyway this is just my humble opinion :blush: No need to continue on the matter.


i had the same issue as you did. I suggest you follow this steps in this post.Try a new installation. You can try and do the partition in windows (by running create disk partition) prior to you attempting manjaro installation:

if you use only Linux

/dev/sda1        vfat       197M    275K  197M   1% /boot/efi

Mine also works perfectly.

Filesystem      Size  Used Avail Use% Mounted on
/dev/nvme0n1p7   34M  5,9M   28M  18% /boot/efi

It is even a dual boot, with 2 different EFI partitions on different drives.

I already put flag boot & esp in partition and still not booting… I did said I did try other Linux and some Linux installer did create flag boot & esp partition and no problem. It just my PC will not boot any Linux in UEFI mode. Not everyone know very well about BIOS, normally people just put default settings and boot into Windows.

I noticed that you EFI’s default boot it’s the hard disk. Have you tried to change that (with efibootmgr) or have you tried to choose the Manjaro entry from the EFI boot menu?

About your computer not being able to boot any Linux, I have to say that it’s odd. I have worked with older Lenovo model (E30) and even it has a buggy UEFI, it is able to boot Linux in UEFI

My PC BIOS only got Hard Disk in boot menu. I cannot find any EFI boot menu in BIOS.

According to the output of efibootmgr -v, you have:

  • 0: Windows
  • 1: Manjaro
  • 4: Hard disk
  • 5: USB
  • 6: Network
  • 8: CD/DVD
  • 9: USB (again).
    Being 4 the default boot

If some of them are not showing up in the actual boot menu, maybe they are old entries that can be deleted. But I guess that at least Windows entry shows up? (And that is not a hard disk entry)

I recommend to disable CSM (aka compatibility mode) to be sure to always boot in UEFI mode.

My PC BIOS don’t have CSM and no secure boot too

Ok. Sorry, in this case my recommendation was in general, not for you :slight_smile:

What do you have in Primary Boot Sequence and what actually shows up in boot menu (F12 at boot)?

it just normal CD/DVD, USB Key and HDD

I just wondering how come Windows 10 can boot UEFI mode without any problem. Linux just cannot boot.

Now I start to remember that yes, my Lenovo didn’t show up the operating systems.

I think I can still get my hands on a Lenovo E30 at work and check Manjaro installation on it. But that would be tomorrow…

Ok Thanks
I notice that your Lenovo E30 is same group of BIOS for my PC Lenovo M81 too

cfinnberg have u check your Lenovo E30?