Manjaro does't boot: "no filesystem type specified"


I tried fixing something and now Manjaro doesn’t boot anymore.

Instead I get this message:

mount:/new root: no filesystem type specified
[...] emergency shell
sh: can't access tty: job control turned off

How can I possibly repair this?

use a live system booted from USB or CD
and chroot
and properly fix what you tried to

Hello Bogdan,

I still haven’t figured out how to repair the bug I mentioned in the link above. Can you confirm that your proposal is fitting what the photo I posted afterwards is showing?



That is plymouth indeed, and what i mentioned about removing it is still valid. On my PC any type of bootsplash/plymouth is not working, hence i can’t test if is possible to fix it.

1 Like

Thanks a lot! I will try it and let you know if it helped.


gdm-plyouth isn’t installed and in the config file this is the only line with plymouth in it:

HOOKS="base udev autodetect modconf block keyboard keymap plymouth plymouth-encrypt resume filesystems"

I assume the advice to delete a line in this file referred to gdm-plymouth?

There is no such package. On Gnome is gdm-plymouth - check again, and if indeed is not installed then the HOOKS should modified be like this:

HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"

Then you run
sudo mkinitcpio -P
so your next reboot there will be no plymouth showing up at boot.
Also, if you use resume, make sure you have the UUID properly set in /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT line …


sounds like I could mess things up as I would have o figure out how to set UUID properly and it looks like if I make a mistake it could prevent my computer from starting or something

Not if you follow the Power management/Suspend and hibernate - ArchWiki
Anyway, if you do not use suspend/hibernate then you can have the HOOKS like this

HOOKS="base udev autodetect modconf block keyboard keymap filesystems"

then run
sudo mkinitcpio -P

and then to be sure you also run
sudo update-grub

then is all good after reboot.

I don’t really understand what’s in the wiki, but the edit you propose for the line just leaves out “plymouth plymouth-encrypt resume filesystems” so shouldn’t resume work and UUID be set up properly already?

Please pay attention, do not focus on what leaves out but what what remains in the HOOKS. You can’t remove filesystems but you included it in your leave out thing …

You did not share the content of /etc/default/grub so i can’t know if is or not set properly.

I’m sorry I meant the edit you proposed above (HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems)

only leaves out: “plymouth plymouth-encrypt” compared to what is already in the HOOKS line in the config file. So I assumed I don’t have to check if UUID is set properly because resume wokred before.
(Please note the I don’t have any idea about programming etc. :grimacing:)

Here ist the content of the file you mention in your last post:

GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0:luks-3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0 root=/dev/mapper/luks-3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0 splash apparmor=1 security=apparmor resume=UUID=97f9ff6f-27bf-448f-9544-8744a7ad79e7 udev.log_priority=3 i915.enable_dpcd_backlight=0"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

There, is set, so yes, you can leave it like this

I tried it and now it doesn’t boot into manjaro anymore.

In the HOOKS line looked exactly like in your last post and then I did:

sudo mkinitcpio -P
sudo update-grub

Now I get this message when I boot:

mount:/new root: no filesystem type specified
[...] emergency shell
sh: canÄt access tty: job control turned off


What did i told you? Not to remove filesystems from the hooks line … either you still did that, or based on how you deal with the code, you did this

instead of this

You see? In your code you missed " at the end, so you probably did the same on /etc/mkinitcpio.conf file.

You will need a USB with the Live Installer and chroot into your installed system and fix it.

At this point i will make this public, so maybe someone else will help you out more.

1 Like

Merged this because people that will help you out should know the context.

Ok I will try to figure it out then :partying_face:

Yes, it is.

It would be much better to create your own thread for your own issue, btw.

two places to look at:
there is an “encrypt” HOOK in /etc/mkinitcio.conf
there is a setting in /etc/default/grub
dealing with encrypted root file systems -it is aptly named

So you actually did change it - no? :wink:

Too complex now to quickly figure this out.

I will be back - in a few hours.

Is your first time posting here so nobody recommended you to do anything previously.
What is the exact system issue you had? Please see

In case you are @rogerR - please see Forum Rules - Manjaro

That is against the Forum Rules as mentioned above. Use the I forgot my password link and reset your password.