Manjaro doesn't work after kernel upgrade

I had a package that couldn’t installed be installed Linux 5.10.1 (default) so I upgraded it by pacman to 5.10.2 (which removed 5.10.1) no my computer boots into a black screen the no hard drive activity ctrl-alt-f1 to f12 doesn’t do anything at all I chrooted into this install and tried Linux 5.11 | 5.12 | lqx 5.12 all had the same result help

Did you upgrade the rest of your packages, or just the kernel? Partial upgrades are not supported.


Nah just the kernel

I will chroot and try to upgrade everything once I have access to the computer and I’ll give you an update

Nah updated all packages still no change

My advice is to “allways” install at least 2 kernels for safety. If one fails, you could boot with the other via grub. Most times i do use one new kernel (like 5.12) and one older LTS-kernel

Maybe you are able to reinstall 2 kernels with mhwd-kernel. This way grub will be updated and all other necessary things will be run.

mhwd-kernel -li

will show your installed kernel

mhwd-kernel -l

will list possible kernels

mhwd-kernel -i linux510

will install kernel 5.10

1 Like

This is ridiculous I have upgraded all packages I reinstalled grub I install 4 different kernels nothing works

Guys imma just reinstall any advice to not make this happen again

Welcome to the community, @Hotrod. Mine would have broken too had I not had hybrid graphics, because I only had linux59, which I guess just became unsupported and my nvidia dkms module broke in this last update. I’ve known for years to keep a couple of kernels installed, but got lazy, I guess. We should both take @andreas85 advice and be sure to keep 2 or 3 tested kernels installed and at least one of them LTS. I know 510 is LTS and sorry for your trouble. Hope your re-install went well. I don’t mind reinstalling so much ever since I learned to manually partition with separate / and /home. When you can save your home partition, re-installs are cake. Hopefully you already knew that.

Yes i did put my home did on a different partition I have everything back and running thx for the advice

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.