Manjaro doesn't show up on GRUB menu and can't boot from USB

Hello, MrMeng here, I need help with my OS installation. I’ve installed Manjato a few months back and it didn’t give me any problems, the GRUB menu worked fine and it showed both Windows and Manjaro (each one has its own SSD). A few days ago I turn on my computer and I didn’t find the Manjaro option anymore, the day before I updated Manjaro using the “sudo pacman -Syyu” command, then I stopped it half way because of necessity, and then I “continued” updating it using not the terminal but the Updating tool you find in the Manjaro store.
Windows boots fine as always without any problem but I can’t get Manjaro to boot, even if I use a fresh made USB.
Now, before writing this post I tried the following:
-Changing some boot settings such as fast boot and secure boot, no change.
-Trying booting Manjaro from an USB stick (made with Unetbootin), when I boot in (both with open source or proprietary drivers) the result is the same “end Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(2,0)”

PS: I know what the Linux mantra says “Look at the guide before posting”, the thing is I can’t understand if it is a GRUB menu problem, a Manjaro OS problem or Windows trying to take control of everything. Joke aside this is my frist post, so if there is something I need to do different the next time let me know, also, I would like to learn from this problem, so feel free to explain as much as you want.
For last but not least some more info I think that could help:
Laptop computer Thinkpad P52, Intel i7 8750H, Nvidia Quadro P1000 (Mobile version), 32GB of RAM, 2SSD for storage (one for Windows and one for Manjaro). Windows boot manager directory in the GRUB menu is “/dev/nvme0n1p2”.
I can still acces the GRUB menu during the boot selection, it didn’t give me problems yet.
My GRUb boot options are:
setparams ‘Windows Boot Manager (on /dev/nvme0n1p2’
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root 4ABC-05BA
chainloader /efi/Microsoft/Boot/bootmgfw.efi"
I tries using all the boot modes available (UEFI only, legacy only and Both).
UEFI BIOS version is N2CET54W (1.37)
Secure Boot is disabled, Boot Mode is quick.

Thank you in advance to anyone trying to help me with my problem.

:+1: Welcome to Manjaro! :+1:

  • Don’t do this!

  • That looks like a bad download. have you verified the SHA1 checksum of your download?

  • An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to help you… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    That means booting into something, even if it’s an older version of Manjaro, or heaven forbid, another Linux.