Manjaro doesn't show up in boot priorities anymore

Can anyone help me with this problem?

I recently updated my BIOS driver with EZ Flash Utility and after that Manjaro no longer show up in bios boot priorities, I can’t boot in Manjaro and only windows boots


I have windows and manjaro installed on same SSD

My BIOS settings

When you first installed Manjaro, did you enable the “legacy boot” feature in your BIOS configuration?

You surely need to reinstall GRUB from the live environment.
Chroot into your system, and reinstall GRUB following the wiki GRUB/Restore the GRUB Bootloader - Manjaro
For UEFI system, basically these three commands:

manjaro-chroot -a

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck


When done don’t forget to


And after successful reboot in the system I issue another sudo update-grub to make sure there is no weirdness in the entries in GRUB (as it can sometimes happen, don’t recall what exactly).

Every time I update my BIOS I have to reinstall GRUB as it resets the entry in the firmware.

1 Like

Windows is not detected from the live environment for some reason. That’s why user has to run again update-grub when it gets access to the normal Manjaro.

1 Like

Yeah I updated my BIOS right after I posted and forgot to reply after I had to update Grub again from real system to re-add Windows to Grub (because I had issues with my Live USB after the BIOS update and had to figure things out).

1 Like

I didn’t change any UEFI settings when installed manjaro 7 months ago. It was working till yesterday and after updating UEFI it won’t boot anymore

So many thanks :pray::pray::heart:
This solved my problem
I was getting mad from yesterday, didn’t sleep till 6a.m. to solve it.
Thank you again :heart:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.