Manjaro doesn't mount USB storages anymore

Hi folks,
my system does not mount USB sticks anymore.
These are my observations:

  • USB devices (keyboard, printer, Android devices :face_with_raised_eyebrow:, etc.) are working
  • using lsusb the USB sticks become detected
  • gparted finds the partition
  • NTFS exFAT and FAT32 file systems are affected. NTFS not checked.
  • I “repaired” both test USB sticks with windows, both working there properly
  • thunar has freezes for 10-15 sec. when I put in an USB stick. The freeze occurs always on startup directly after the desktop came up. The background image loads after the 15 sec. Also the system does not allow any input during this time
  • I started thunar via console to check any messages during the freeze, but it stays empty.

Would be nice if someone could help searching. I’ve no clue even where to look at.

Best regards, gnampf

just in case

OS: Manjaro 23.1.3 Vulcan
Kernel: x86_64 Linux 6.6.10-1-MANJARO
Packages: 1695
Shell: bash 5.2.21
DE: Xfce4
WM: Xfwm4
Disk: 278G / 439G (67%)
CPU: AMD Ryzen 7 5700X 8-Core @ 16x 3.4GHz
GPU: NVIDIA GeForce RTX 2080 Ti
RAM: 7499612160-

check the forum for ntfs and you’ll find a lot how to solve it.
like this one:

1 Like

I suspect it has something to do with the removal of an ancient package manjaro-hotfixes.

The package contained a rule which at the time of creation solved an issue.

The issue it solved has been long gone but apparently users has become accustomed to functionality provided.

Please post the content of your /etc/fstab using this command

cat /etc/fstab | curl -F 'file=@-'

Provide the url returned inside a codefence like this example


Thank you for the answer. I’ve seen this ntfs topic during my own research, but assumed that in my case this can not be the issue. Because on stick uses fat. Additionally I rechecked that saw that my second USB stick is using exfat instead of ntfs. I corrected my post.

Here is the fstab.

Regarding the lower 4 entries. There is a NAS but I’ve trouble with the NFS mount since a long time. So I’m experimenting a little. A complete different topic.

BUT. I found out something new. Sometimes I using Krusader. Krusader can “see” the plugged USB drives and mounting them instantly. Then they appearing in thunar as well. Thunar has these still these freezes after opening.

# /etc/fstab: static file system information.

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=665a31a2-32de-4f22-9490-xxxxxxxxxxxx /              ext4    defaults,noatime 0 1
UUID=da89332a-b82b-4070-9c1a-xxxxxxxxxxxx /home          ext4    defaults,noatime 0 2
UUID=1A87-A3C3                            /boot/efi      vfat    umask=0077 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0 /run/media/tf/music nfs users,auto,soft,rw,exec 0 0 /run/media/tf/NAS nfs users,auto,soft,rw,exec 0 0 /run/media/tf/video nfs users,auto,soft,rw,exec 0 0 /run/media/tf/photo nfs _netdev,users,auto,soft,rw,exec,x-systemd.automount,x-systemd.mount-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

If it is working when you are using a different file manager - it is not the system itself - but you have narrowed it down to Thunar.

There has been various topics over the years relating to Thunar, I don’t recall any of those to be related to removable devices though.

I am assuming your system is up-to-date - implying a regular run of pacman -Syu.

Also assuming the package gvfs is available.

For the nfs mount see [root tip] [How To] systemd mount unit samples and the parent topic [root tip] [How To] Use systemd to mount ANY device

Yes, the system is up-to-date.
Thank you for the support.
I close the topic and make a dive to the thunar and the system.d mount stuff.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.