Manjaro doesn't load: A start job is running for Hold

I have Manjaro and Windows on dual boot, after some time spent in Windows, and booting in Manjaro I see this line:
[* ] A start job is running for Hold until boot process finishes up (6s / no limit)
And it waits 6s and then it shows black screen

I tried:

  • Booting with another kernel (I had 6.1, tried booting with 5.10)
  • Uncheck Fast Startup in Windows

By the way, I tried installing nvidia drivers, maybe it has something to do with this issue?

Hi @svet,

From that I just saw here, it seems to be because of, or have something to do with plymouth.

So I’d suggest boot into a live ISO, enter a chroot environment, uninstall plymouth and install grub.

More info:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

No, I don’t use plymouth so I can’t be more detailed than this.

Further references: