Manjaro doesnt go sleep when i close lid

Hello there
this is my first time using manjaro, and the first time here too.
I faced a problem that i closed my laptop at 6AM and it was fully charged (100%), then when i open it at 6PM the battery was about to dead (1%)
I searched alot about this issue but i found a (Laptop mode tool) but im searching if there’s another way that will make manjaro goes sleep automatically when i close lid
because sometimes my little brothers use it and its difficult to them to use Laptop Mode Tool.
Thanks alot everyone.

HI, you didn’t provide any system info or the steps you have followed to solve it at all though, and without input there can’t be any output, no?

As a start in the Rules & Notices Category there is this sticky thread How to provide good information, please read and post at least system information in the proper format.

Hi, @jemi_zl
In Settings / Energy Saving you can set this options. Afterwards, remember to push the buttom Apply in order to save your custom settings.

when i ran inxi-Fazy
this is the output
Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64
root=UUID=93c7034b-b527-4b03-9dd8-57922091544b rw quiet acpi_backlight=vendor
Desktop: GNOME 3.36.5 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> Mobo: HP model: 80CC v: 99.46 serial: <filter> UEFI: Insyde v: F.20 date: 01/26/2016
Battery: ID-1: BAT1 charge: 28.7 Wh condition: 28.7/28.7 Wh (100%) volts: 16.6/14.6 model: 131-42-6E HS04041 type: Unknown serial: <filter> status: Full
Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics
bits: 64 type: MCP arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030105 L2 cache: 2048 KiB flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14379 Speed: 998 MHz min/max: 1000/1800 MHz boost: enabled Core speeds (MHz):
1: 1028 2: 997 3: 998 4: 998 Vulnerabilities: Type: itlb_multihit status: Not affected Type: l1tf status: Not affected Type: mds status: Not affected Type: meltdown status: Not affected Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling Type: srbds status: Not affected Type: tsx_async_abort status: Not affected

Graphics: Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu bus ID: 00:01.0 chip ID: 1002:9851 Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 chip ID: 1002:6660 Device-3: Microdia HP Webcam type: USB driver: uvcvideo bus ID: 2-1.1:3 chip ID: 0c45:651b serial: <filter> Display: x11 server: 1.20.8 compositor: gnome-shell driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.7.19-2-MANJARO LLVM 10.0.1) v: 4.5 Mesa 20.1.7 direct render: Yes

Audio: Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:01.1 chip ID: 1002:9840 Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1022:780d Sound Server: ALSA v: k5.7.19-2-MANJARO

Network: Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl v: kernel modules: bcma port: 3000 bus ID: 02:00.0 chip ID: 14e4:4365 IF: wlo1 state: up mac: <filter> Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 chip ID: 10ec:8136 IF: enp3s0 state: down mac: <filter>

Drives: Local Storage: total: 465.76 GiB used: 16.68 GiB (3.6%) SMART Message: Required tool smartctl not installed. Check --recommends ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A3J0 scheme: GPT

Partition: ID-1: / raw size: 20.00 GiB size: 19.56 GiB (97.81%) used: 13.59 GiB (69.5%) fs: ext4 dev: /dev/sda8 ID-2: /home raw size: 79.49 GiB size: 77.75 GiB (97.80%) used: 3.09 GiB (4.0%) fs: ext4 dev: /dev/sda9

Swap: Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) ID-1: swap-1 type: file size: 256.0 MiB used: 0 KiB (0.0%) priority: 50 file: /var/lib/systemd-swap/swapfc/1

Sensors: System Temperatures: cpu: 57.4 C mobo: 20.0 C Fan Speeds (RPM): N/A GPU: device: radeon temp: 56 C device: radeon temp: 56 C

Info: Processes: 211 Uptime: 4h 20m Memory: 4.77 GiB used: 1.72 GiB (36.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1215 pacman: 1213 lib: 338 flatpak: 0 snap: 2 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05
i dont know if these the correct information

i dont find “Energy Saving” in the “Settings”
Should I install something to show it?

Hi, sory. System Settings / Power Managment / Energy Savings.


I have this in power in setting
is it the same power managment?

Hi @jemi_zl
I did not see any problem in the power management except you set the power button to suspend the laptop.
Maybe, you have to press it. I do not see any action when you close the lid on the Power configuration image you sent.
Hope it help

I can’t see any pics on my school PC, so bear with me for now :sweat_smile:

Anyway, it appears you’re using GNOME from profile info anyway, make sure you check in Settings – if you don’t see it anywhere in the application menu, make sure gnome-settings is installed. From there, just open Settings, go to Display or Power, and it should be there.
If not, checking out gnome-tweaks might be worth a shot, I recall there being an option for it in there.

Thank you all
i dont really know if i did it or i was missing something
but i did use these commands

pamac install tlp
systemctl enable tlp --now
pamac install powertop

and the laptop is doing right
Thanks a lot

tlp is installed by default with every Manjaro “install” (.iso) version, “minimal” or “full”, so maybe the service was somehow disabled in your case. I am on Plasma (KDE) and not on Gnome as you -that’s why your system info output is always crucial, as different settings are in different places in every DE- but I’ve managed to look for that setting in a Gnome “environment”. For future reference it’s under “General” in Gnome Tweaks, so make sure you have gnome-tweaks installed.

P.S. Post big chunks of text like those of system-info between 3 backticks ` at the start and the end of it like this:

    big chunk of text


Give it a try, editing your post :wink: