Manjaro does not start from Grub dual bootloader

I am struggling ( as a new linux-Manjaro user) with a problem since last week, I did a lot of reading and searching for similar problems on this forum and i watched videos and I have no clue on how to get Manjaro up and running.

I have Manjaro ( KDE plasma) on a drive and I have Window11 on a second drive and I use Grub bootloader for dual boot ( see image 1)

This setup was working perfectly since may 2023 and since last week, I can no longer boot Manjaro . I can boot Window no problem. In Manjaro, I use mostly photo editing software so I do not make any changes to Manjaro configuration. The last time that Manjaro was working, I installed an Apimage of DigiKam. When i turned off the computer, Manjaro took a lot of time to shut down.

Now, when I boot Manjaro, I get an error message : «/boot/vmlinuz-6.1-x86_64» is not available and the kernel needs to be loaded (see image 2)

I found some information on grub commands to see if the configuration file was pointing at the right file structure ( hd0,gpt3) and it seems to be OK ( some videos mentionned possible file corruption in Grub.) ( see image 3)


1 Should I try to reboot with an USB drive ? I am concerned that this will delete my partitions. I have a common partition with Windows (400 Gigs with data )

2 Any other suggestions or hints on what I can do to get Manjaro up and running ? ( There is a lot of documentation and ressources on how to fix a problem once Manjaro in up and running)

King regards and thanks for taking the time to read my message and make some suggestions or point me in the right.

this looks like a messed up update, you need to reinstall the broken kernel(s)…
boot into manjaro live usb, make sure you are connected to internet, open terminal and chroot:
manjaro-chroot -a
(this manjaro-chroot -a command doesnt work with btrfs and/or encryption…)
rerun update:
pacman-mirrors -f 5 && pacman -Syyu
if there are errors post the output here, if there are no errors and you are up to date, check output from:
ldconfig - (this should return nothing), if it does, run:
mhwd-kernel -li
and reinstall all kernels listed in the output, for example:
pacman -S linux515 linux61
if you are using nvidia, reinstall the modules too, for example:
pacman -S linux515-nvidia linux61-nvidia
if there were errors, post them here, if there were none, exit chroot:

Thank-you brahma for your fast response.
I rebooted Manjaro with a USB and followed your instructions and the following image shows all the commands and the results.

I exited and rebooted the PC and the same problem occures when I select Manjaro from Grub bootloader: Manjaro does not start.

I hope that you have a few minutes to help me out.

Kind regards

Well you didnt do any updates.
It failed with

error: failed to synchronize all databases (unable to lock database)

The mhwd command afterwards likewise failed for the same reason.

So … there is a problem and you did not make any changes.
Of course it is the same result when you boot.

Maybe you should remove the lock file and try again.


manjaro-chroot -a 
rm /var/lib/pacman/db.lck
pacman -Syyu linux61

Hello CSCS,
Thank-you for your response, I entered your commands and the fail to synchronize error still occurs. see image:

Thank-you to take some time to suggest other command lines to help me out. All this is very new to me.

You have a typo.
You did not put a space between rm and the file path.
(thus nothing was deleted)
Though the error did change somewhat nonetheless, which is interesting.
Anyhoo … run the command(s) again please and make sure to include all the spaces. :slight_smile:

Now Manjaro boot fine but my Grub dual booter ( Windows and Manjaro) is gone. When I restrat my computer, the Grub does not appear and starts up Manjaro directly.
Is there a way to reinstall Grub dual boother?
Thank you for your help.

You may wish to run again

sudo update-grub

Otherwise you may want to investigate the options in /etc/default/grub.

Hello CSCS
Thank-you for your good support. Everything works well, Manjaro, Windows and the dual bootloader.

Glad it worked out :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.