Manjaro does not change screen brightness

Using the fn key, the animation appears but the brightness does not change. I activated brightness change in settings. I tested it on Xorg 11 and Wayland. It’s the first time I use manjaro and I can’t solve the problem.

I also have the same problem on my Asus Tuf Gaming A15 (2022) laptop. If I use any kernel above 5.15 (LTS), including 5.16, 5.17 etc and all kernels starting with 6, the screen brightness/backlight is locked to max. It’s just too bright. I tried switching between x11 and wayland on the login screen but it didn’t change anything. I don’t know what they’ve changed after the kernel 5.15 but it removed my laptop’s capability to reduce backlight. The brightness slider can be seen on the screen when I press Fn+F7 or F8 but it doesn’t change anything.

I’m using KDE Plasma. Everything is up to date. I’m using the open source drivers for the nvidia gpu but I mostly use the integrated amd gpu anyway. If there’s any info I need to provide, please tell me what it is and how to get it. I’m not very familiar with terminal commands.

Strange, I had the exact opposite problem. Before kernel 5.16 my brightness was locked to max. Haven’t had a problem with it since 5.16. I’m running the proprietary Nvidia drivers, though.

I had a similar problem with my laptop as fn keys did not work!
I installed brightness-controller-git from AUR and solved that problem.
You can also try the command-line tool brightnessctl from manjaro repo as well.

A bit more information about my issue, fn keys did not work with kernel 6.1 LTS (only noticed a month ago) then I installed brightness-controller-git to be able to control screen brightness.
I had three kernels installed: 5.15 LTS, 5.19 and 6.1 LTS (uninstalled 5.19 when went EOL), the issue with fn keys only appeared with kernel 6.1 LTS, on other kernels mentioned fn keys work normally. On kernel 6.1 LTS did not have any other issue, everything else works ok!
If I’m not mistaken you could also solve that brightness problem by editing something on grub, if anyone with more experience and knowledge know how please share it.

1 Like

Thank you for your suggestion. I installed brightnessctl from the official repository and it worked on kernel 6.1.49-1 LTS. After the installation, I simply needed to open up a terminal window and type:

brightnessctl s 0%

s means “set”, 0% reduces brightness to minimum. It would be brightnessctl s 50% for medium brightness. (I wish I could reduce it further below 0% as my screen is quite bright). After changing it this way, I hoped the regular brightness slider would magically start working but it didn’t. Still, it’s something.

However, as I feared, I experienced a sudden random reboot while browsing the internet. That’s the other issue I have with kernels above 5.15 LTS. System randomly locks up and then immediately auto reboots. I hope the dev team will fix it eventually. In the meantime, thank you for the workaround. I remember this utility having a graphical user interface back when I had an ubuntu based distro which would let me move a slider to adjust the brightness instead of typing commands. Not sure if the aur version has it; I usually try to install as few aur packages as possible because I lack the technical knowledge to solve problems when broken packages start to mess up with the system or updates. However, for other newbs like me out there, I have already posted how the terminal commands work above.

I haven’t tried installing proprietary nvidia drivers. If I do and it solves the issue, I’ll post about it, too.

For my acer laptop, I need to add acpi_backlight=native in /etc/default/grub then reboot to make fn keys work.

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 acpi_backlight=native"

See Backlight for more information.

1 Like

I have installed nvidia’s proprietary drivers and it solved 2 problems I had on kernels later than 5.15 LTS.

  1. Screen brightness now works without any issues. I no longer need to use the brightnessctl utility.
  2. Random system crashes that result in auto reboots seem to be gone. I’ve been using my laptop for hours, watched videos on it, browsed the internet, played a game for some time and haven’t seen any crashes yet.

It seems that my problem was the open source nvidia drivers. My manjaro installation is currently running on kernel 6.5.0-1, which is the latest one available at the time of writing this. The only downside to this is the closed source drivers. I prefer going full free and open source.

Great! Glad it worked out for you.

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 acpi_backlight=native" worked for me! @medmedin