Manjaro does not boot, most likely nvidia driver at fault

the System of my son does not boot to KDE anymore.
Its not 100% sure what he did but most likely it was an update and/or using the off-switch because an installer on steam froze (no, he will not do this again).
By now I’ve tried quite a few things. Updated the system, installed newer Kernel, that actually helped but its still stuck at boot after “Finished TLP System …”. Despite of that I think narrowed it down to nvidia drivers because of an log-entry in journalctl:

Nov 25 18:24:00 user kernel: NVRM: The NVIDIA GeForce GTX 660 GPU installed in this system is
                               NVRM:  supported through the NVIDIA 470.xx Legacy drivers. Please
                               NVRM:  visit for more
                               NVRM:  information.  The 495.44 NVIDIA driver will ignore
                               NVRM:  this GPU.  Continuing probe...
Nov 25 18:24:00 user kernel: NVRM: No NVIDIA GPU found.


[user@user-1 ~]$ inxi -Gazy
  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: N/A
  alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:11c0
  class-ID: 0300
  Display: server: driver: loaded: nvidia tty: 317x93
  Message: Advanced graphics data unavailable in console. Try -G --display
[user@user ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!
[user@user ~]$ sudo mhwd -a pci nonfree 0300
[sudo] password for user:
> Using config 'video-nvidia-470xx' for device: 0000:01:00.0 (0300:10de:11c0) Display controller nVidia Corporation GK106 [GeForce GTX 660]
Error: config 'video-nvidia-470xx' conflicts with config(s): video-nvidia

removing video-nvidia does not work, since it has tons of dependencies.
I would be grateful if anyone has an idea.

Kernel: 5.4.159-1-MANJARO (same problem with 5.15, 5.16 …)
CPU: AMD FX-8350 (8) @ 4.000GHz

Think about checking Stable Announcements.

1 Like

As I said “sudo mhwd -r pci video-nvidia” does not work.

+> Removing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency 'nvidia-utils' required by cuda
Error: pacman failed!
Error: script failed!

Removing nvidia-utils also does not work. Has something to do with CUDA.

What kernel are you using?

Does not seam to make any difference.

I had the same issue, albeit with a different nvidia card plus a nasty unknown ‘moun’ efivars error.

I downgraded the kernel to 5.13, reinstalled the proprietary nvidia driver (Nouveau doesn’t work), and now it works fine…

Unfortunately I cant uninstall the driver… that’s where I’m stuck.

Have you tried from a chroot environment?

No, but I’m a little afraid to break the system.

Understandably. It is something you’ll have to do.

Think of it this way: it’s a lesson. An important one, too.

And manjaro-chroot makes it much, much easier. I wouldn’t have done it either, if it wasn’t for that.

And the system is already broken,the chroot can repair it. I know the worrying feeling all too well. But it is something that can be conquered.


I’m off to bed, but I have many tutorials here, on the forum that’ll help you. Look around and grab one.


So remove cuda, install the nvidia drivers, reinstall cuda?


Yes, in the end I did exactly that. All went better than expected.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.