Manjaro does not boot after update - emergency shell

Hi @GaVenga, in case I didn’t make it clear, the screenshot with Memory Tester is just to demonstrate to @TriMoon what screen I used to see for login. That picture is from a guide to set up dual boot, it’s not from my system.

Both my OS, Manjaro and Windows are UEFI. I know this for a fact as I had to reinstall windows in October before installing Manjaro.

Without at least knowing what you do you should not defuse a bomb - or driving a car which is a weapon too.


btrfs as root-system needs a special bootloader afaik - some years ago I struggled with open SUSE
and the final solution was not so easy.
Expert required…

Thanks but you are actually not demonstrating it for me personally, it is helping others to help you better :wink:

Sure, no problem. Context is I have a dual boot system. It had Windows originally, and I added Manjaro in October.

What used to happen

If I turn on my laptop, I’d see a screen with 4 options. Two options to choose either of the OS, one for Manjaro custom settings and one for UEFI options. I belive this is called the Manjaro bootloader screen (based on this page), but I may be wrong. It looked something like this (from the previous link), but I used to UEFI as the last option instead of Memory Tester:

Then if I select any of the two OS using cursor keys and press enter, I’d have reached the page to provide user credentials and that’s it.

While problem started yesterday morning, I was still reaching the above page. If I had selected Windows, no problem and everything was working as it should.

If I had selected Manjaro, then it was showing me the error that I shared in the main question.

What is happening

I applied what @GaVenga suggested in the evening. While I ran sudo update-grub, I received this:

I interpreted this as they removed the old entry for existing installation and inserted a new entry on top. I may have understood completely wrong, so sorry about that. Anyway, if I turn my laptop on after that, it is immediately going to the following page:

Let me know if this info is what you wanted.

So, I am not getting a chance to log in to Windows easily. While turning on the laptop, I have to press F12 to go to boot settings and from that Windows option is coming. This is just an inconvenience, which I am happy to ignore for now.

I totally agree we need something that will prevent this ever happening again.
The reality is that unlike the experts we just want to use our computers to do our work.
While it’s working to our satisfaction we don’t want to fix it.

On rare occasion that we do want to update something then we can make sure our backups are up to date first before giving it explicit command.

Thus at the moment I’m looking for a way to kill the automatic update checking and all the nagging about new packages. My backup system I disconnected the moment it too came up with umpteen package updates and haven’t dared connect it to my router again. I can’t afford to lose that too.

So my question is how do I kill the updates and make them on explicit request only?

There are no automatic updates. You are in charge. You are only being notified that there are updates available. If you want to be on the safer side, don‘t update immediately but read the announcement for that update here on the forum. It will give you an idea of how the situation is.

There is no use in not updating to avoid trouble. Updates are there for a reason. Apart from bringing new features there are security updates.

By choosing Manjaro as your Linux distribution you also choose to be close to the constantly rolling (means updating) Arch Linux, which is where the majority of packages come from. That‘s why you get „nagged“ with updates regularly. Not performing updates for an extended period of time will likely get you into more trouble as Manjaro is not meant to be run like this.

Most of the problems can be solved in some way and the probability to run into such problems varies greatly with your specific hardware combination.

In general running a linux system sometimes requires a little bit of reading, learning, trying and such. If you are not willing to do that from time to time it is probably not the best choice for you.

Also please keep in mind that there is a small team behind the scenes and not a huge company with unlimited resources…


this looks like mixing UEFI and NO-UEFI, because in a UEFI-System
the Grub-menu does not show the entry: “Memory-Tester…”. Never.
But the line “Adding boot menu entry for UEFI Firmware Settings …” indicates
that Manjaro is installed as UEFI.
If Windows is installed in UEFI-Mode, you probably try to start from the wrong boot-device?1
====> BIOS ===> boot-entry which ist first bootable device.
Maybe there is a possibility to select boot-device by pressing “F8” or" F12" before Grub-menu?

1 Like

I do understand that, and I confess to having had worse problems with Windows that does updates whether you want them or not. I’m definitely prepared to read up on stuff and that’s why I was looking for solutions here. I’m sorry if I came across as a bit miffed as I had just realized I had not backed up a folder of work that I can’t recreate…

All of today has been consumed setting things up again and I still haven’t got my virtual hosts to work on Apache. (Keep getting 403 error. It appears to be a common problem with many possible causes and it must have been fluke I didn’t have problems the first time I did it).

There are little things I’ve been struggling with like I just realized my system time and date has jumped 12 hours ahead with installing. It appeared to be right this morning, but I suspect that applying the time zone (GMT+12) it didn’t realize that was the time the clock actually was already set to. Now it’s not obvious to me where to correct this, so that’s another thing to google…

For consistency sake I prefer to use the same operating system on both my computers even though the backup-pc would not really need any updates: All it does is put a large hard drive on my LAN and nothing much will change with that ever while I just don’t want to risk wiping it.

And you want to drive a car without without taking a driver’s license
because the car is so pretty and you only want to drive to anywhere…?
Golgafrinchan Ark Fleet Ship B - they invented the wheel, but could not find the right color for wheels…

I’m not claiming to be a top racing car driver, but I do know how to do the work I do.
Isn’t it more like driving a car without being a motor mechanic?

yarabrina seems to run NVIDIA card - this seems to be the main problem actually:

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.
    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:
sudo mhwd -a pci nonfree 0300

If proprietary drivers don’t fix everything, please click the ► at the beginning of this line to view more info

If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our [tutorial on compiling old Nvidia drivers]
([Support/How-To] Compile old/legacy Nvidia Proprietary Drivers [2020-12-30 Update Issue]).[[Testing Update] 2021-01-02 - Linux 5.10, Themes, Deepin, Haskell, Python]
([Testing Update] 2021-01-02 - Linux 5.10, Themes, Deepin, Haskell, Python)

After chrooting from live ISO, try regenerating the initramfs images:

mkinitcpio -P

Alternatively reinstall the kernel package. (That will also trigger mkinitcpio as well as update-grub.)

pacman -S linux510


I completely understand. After I posted an hour back, a lot of split/merge had taken place, and the order of the posts got changed and the context is gone. So, please ignore that post of mine. Sorry!

Let me try the solution @moson suggested, and go through @GaVenga’s wiki post. I’ll update if it works.

It is related but im my P.O.V. the most urgent issue at moment is the ability to boot via Grub: GRUB/Restore the GRUB Bootloader - Manjaro
The nVidia problem can be solved after that by going into another VC.

Take note that especially with dual-boot setups involving M$, you should set your BIOS time to be in UTC, and do some registry stuff so that M$ also uses UTC.
Otherwise you will keep that problem because Linux in general is using UTC as hardware clock setting, which M$ is doing wrong…

1 Like

Seems boot problems and NVIDIA problems are linked to each other, first load the nouveau driver
and then fix the rest? (after chrooting: sudo mhwd -a pci free 0300)

Anything that allows to boot into the system and access the console in text mode will do :wink:

You are right…

Hi! Well I gave a shot combining @GaVenga and @moson’s suggestions, and I am able to boot now. I do not know which one is actually responsible for the success, so thanks to both of you.

For anyone else facing this, these are the commands I ran on sequence:

sudo manjaro-chroot -a
sudo pacman -Syyu
pacman -S linux510

After reboot, I was able to login and everything seemed normal.

I should add that there was a lot of warnings and some errors in the screen. I captured those using script command. I uploaded here: Gofile.

If you can help me understanding whether these are serious or not, that’ll be very helpful. I haven’t tried anything for NVIDIA driver issue from command line yet, but I while chose to auto install driver from Manjaro Settings, it returned success. Let me know if that is not enough or not recommended.