Manjaro does not boot after fresh install

I’ve been trying to install manjaro for a while now and it failed like 6 times. The partition details are below

partition         size                                 flag
256 GB SSD
/dev/sda1      100mb   windows EFI
/dev/sda2      16mb     windows
/dev/sda3      196gb    ntfs
/dev/sda4      1G          /boot/efi                   boot
/dev/sda5      2g           swap
/dev/sda6      27G        /                            root

/dev/sda1        500gb      ntfs
/dev/sda2        500gb     /home

after install it gets stuck at “acer” logo and does not display anything but the logo. I’ve tried to install it multiple times it does not work, i tried to install it with a previous version manjaro gnome 20.2 RC4, it had similar issues but it booted when i selected fallback mode in grub but the installation broke when i ran

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

After all of that i reinstalled the latest version, again with the same issue,
i tried the following after chrooring into install :

mkinintcpio -P

this still did not work, so i tried changing the nvidia drivers .

mhwd -r  pci video-linux
mhwd -i pci video-nvidia-450xx

when i tried to install nvidia driver it returns " video-nvidia-450xx not found" .

i’ve had the same setup a month ago and it worked like a charm, now it fails every time i install it. before installing manjaro i had ubuntu in the same setup (ive deleted all of ubuntu’s partition while first installing manjaro).

i also have nvidia 940mx graphics card in my laptop

Looks like gdm does not start causing manjaro to be stuck on acer logo

Press ctl +alt +F3 to enter command line mode and then i switched to wayland instead of xorg. GDM was not starting up properly. but you can also issue startx to start gnome once you are in command line mode

can you provide

inxi -Fza
sudo mhwd -li
sudo mhwd-kernel -li

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.