Manjaro Deepin - certain global shortcuts not working, regardless of keybind

New to Manjaro and Deepin here.

The maximise, and restore shortcuts (set in Control Center → Keyboard and Language → Shortcuts) don’t do anything, no matter what keybind I set them to. Additionally, all the screenshot shortcuts (Screenshot, Delay screenshot, Full screenshot, Window screenshot, and Screen Recorder) worked when I first installed the OS (yesterday) but now do not - again, regardless of what I set them to. The only thing I can think that I changed that could in any way affect it was setting the keyboard layout with setxkbmap -layout us,us -variant dvorak, as per the end of this link: (side note: even when setting both Dvorak and QWERTY layouts with setxkbmap, only Dvorak (the one I chose in the initial install) shows up in Keyboard and Language → Keyboard Layout). It is possible that the maximise and restore shortcuts worked when the screenshot ones did, but that I didn’t try to use them until afterwards.

Any help here would be greatly appreciated.

Welcome to the forum! :slight_smile:

I am not a developer, and so I’m not certain yet, but there does appear to be a problem with keyboard settings and shortcuts that spans different desktop environments, as you can read in this thread below… :arrow_down:

This is kind of embarrassing, but the reason the screenshot/screen record keybinds weren’t working was because I didn’t have deepin-screen-recorder installed. To fix this, I just ran pamac install deepin-screen-recorder - this is what the shortcuts try to use to take screenshots/recordings, so obviously if it’s not installed, they won’t work.

Also, poking around in ~/.config/kglobalshortcutsrc showed that Window Maximize was set to Alt+F10, despite Control Center saying it was Super+Up. Alt+F10 works, and although I haven’t tried to modify it, I presume it would work if it was changed, so long as what it was changed to was not already bound.

1 Like