Manjaro Cinnamon, suddenly for no reason can't type a 'd' button in the terminal

For the first time that problem was fixed when I moved to the older version of the kernel. Restart don’t help, moving to the older snapshot maden with Timeshift also didn’t change it. Switch to an other keyboard too don’t help(a4tech x7 and logitech k400+). The same in the nano, it`s also won’t type ‘d’, I have tried different terminals - WezTerm, Byobu, Xcfe, Gnome, Deepin, even virtual keyboard give no effect.
I didn’t change any of the shortcut but anyway tried to set it to default - no effect.

The only way how I can type d in the terminal it’s + shift or CAPS but of course it’s typing ‘D’ instead of ‘d’, or after cat. And thankfully I still can paste ‘d’ alone or command that’s including it like ‘sudo’.

I never had this problem before, with Manjaro KDE and with Linux Mint Cinnamon it’s was fine

This happened even after I had installed Manjaro KDE and restored my backup with a Timeshift.

The cinnamon evelopers banne the key because a lot of swear wors contain that character. :stuck_out_tongue_winking_eye:

Just kidding. So it’s only in the terminal?
I guess something is screwed up in your .bashrc (or whatever shell / config your are using)

Yep, only in the terminal this problem occurs.

Suspiciously sounds like a config problem.
Try with a new/fresh user. If the problem doesn’t present there - you can copy your configs

  • one at a time
  • in a bisect way (considerably faster)

to identify the problematic one.

1 Like