Manjaro cinnamon desktop resets to default after reboot

Hi all,

I’ve installed Cinnamon community edition on Manjaro 20.2 and I’m loving it. In installed the Cinnamon DE using the instructions on the Manjaro Wiki. For some reason though, my desktop background keeps reverting to the default community edition background. If I go to change desktop background, go to settings, and change the picture aspect to stretch, my chosen desktop pops back up. This is strange because it means that I have succesfully set the background but for some reason whenever I log in I need to select ‘stretched’ again for it to show up. Is there some sort of permission issue here? Could it be some issue in the LightDM config when I installed the DM.

I’m a complete noob here so any help would be much appreciated. This is a small pet peeve but I’d love to get it fixed.


Greetings. I don’t fully understand, you installed Cinnamon through Manjaro Cinnamon iso? Or you installed above another DE, let’s say Gnome, via terminal/Pamac?


So I installed the default xfce edition from an iso. Then I installed cinnamon using the terminal, using the instructions available here.

I didn’t create a new user because I don’t plan to use the xfce desktop. Thanks.

Manjaro has additional specific Cinnamon packages, for customizing the DE. I dunno if it’s installed automatically as dependencies or if they have to be installed by yourself.

But frankly, if you don’t want XFCE, just save your data somewhere and reinstall Manjaro directly with Cinnamon iso. Because your system has both XFCE and Cinnamon configs/dependencies.

@watdryhope two questions;

When you say you “chosen desktop”, you are referring to your wallpaper correct?

Also, are you using the installed wallpapers or are you using your own, if so where are you storing your wallpapers?

I’ve already installed it twice so I’d prefer not to have to do it again if possible. Could I install using cinnamon iso and then timeshift back without the xfce? assuming the xfce will be in the timeshift.

Sorry I meant wallpaper. @DeLinuxCo. I meant the wallpaper resets to the default. I’'ve just got it in my pictures folder but also used root to move a copy to the backgrounds folder but the same problem keeps happening

Post output of ls -la /home/$USER | grep root please … this might reveal something. Maybe some files &/or directories in your now modified /home have wrong ownership. I have never attempted installing a second DE so there are some unknowns including this one. Never a good idea IMHO due to potential conflicts. :wink: :smiley:

Also, have you put those wallpapers in one of the default directories or are they maybe in one which doesn’t get mounted before the wallpaper is supposed to be loaded and displayed?

Yes to Timeshift… Hold down the Ctrl key and select the individual folders you want to restore. But don’t restore any hidden XFCE settings folders or files. Take a screenshot of your Timeshift settings and save it to your back up drive. If you don’t remember the settings, you won’t be able to restore anything.

hi all, thanks for the info. I was actually able to solve it. Looks like there was an issue with xfce. I went into Xfce and changed the desktop background folder to the folder where I had my cinnamon desktops in there and now I have no issues with CInnamon. Is it safe to now unnstall Xfce and keep the dependencies somehow?

the odd thing about above is that the desktop I chose for xfce wasn’t showing up in cinnamon, the default community edition one was. it seems to be fixed now.