Manjaro cant see wifi


I have recently installed Manjaro in a Mini PC ACE Magician AMR5 in dual booting with windows 11. The problem is that it does not detect wifi. The wifi works just fine in windows 11.

I tried many solutions found in the forum but none of them works.

I am running on the kernel : 6.1.49-1-MANJARO (linux61)

Here is some outputs that might be useful :

inxi -Naxz                                                       ✔ 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000
    bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Realtek driver: N/A modules: wl pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:b852 class-ID: 0280
 rfkill list                                                      ✔ 
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

nmcli dev status                                                 ✔ 
DEVICE      TYPE      STATE                   CONNECTION         
enp4s0f3u2  ethernet  connected               Wired connection 2 
lo          loopback  connected (externally)  lo                 
enp1s0      ethernet  unavailable             --     

Hi @ayoubana, and welcome!

This :point_up: might be why. There seems to be a driver missing. According to this website:

The device is supported by kernel versions 6.2 and newer according to the LKDDb:

So it would seem your network adapter is quite new.

But the driver is in the AUR:

$ pamac search 8852
rtw89-dkms-git  1:r327.e834edf-2                                                                                                                                                                                                                          AUR
Driver for Realtek 8852AE, an 802.11ax device

Since it’s from the AUR, you need to make sure you have all the required packages installed. To make sure they are, run the following:

pamac install base-devel $(pamac list --installed --quiet | grep "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

If that was successful, you can build the drivers:

pamac build rtw89-dkms-git

If successful, reboot and test.

If it worked, feel free to heap on the praise. If, however, it didn’t, well, then I’m innocent and not here…

1 Like

Perfect, it is working now. Thanks a lot!

1 Like

update: Now when I suspend and log in again, it does not read the available networks !? I have to reboot to be able to connect to an available wifi.

After wakeup, when it’s not working, what’s the output of:

lsmod | grep --ignore-case 88

Also when I work with wifi for ~ 10 min, samething happens…

 lsmod | grep --ignore-case 88                           PIPE|2|1 ✘ 
rtw_8852be             16384  0
rtw_8852b             352256  1 rtw_8852be
rtw89pci               81920  1 rtw_8852be
rtw89core             593920  2 rtw89pci,rtw_8852b
snd_hda_codec         188416  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
cfg80211             1138688  4 wl,rtw89core,mac80211,rtw_8852b
nvme_core             208896  3 nvme

Does your WIFI return if you run:

echo 1  | sudo tee /sys/bus/pci/rescan

…while your WIFI is still not working?



Rather start a new thread, so that it’s not just you and me here, because I’ll shortly be off.

No it does not!

The WIF is on, but no network appears…

In the new thread, provide:

inxi -Naxz

…from before the suspend, as well as after, when it’s not working.

This is a different problem since the original was fixed, so a new thread is the best.

Feel free to reference this thread.

To be honest, getting new eyes on the problem will help, and lots as well, since I don’t use WIFI, so don’t have experience with it.

Another thing you could try, is using a kernel newer than version 6.2.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.