Manjaro can't find a partition to install on

I’m installing Manjaro XFCE on a dual boot system with Windows 10 on my new Lenovo ThinkPad T14 AMD system, but the install is telling me there are no partitions to install on. I’ve done a little searching and I found a post where someone says to go into the BIOS and change the SATA controller from RAID to AHCI, but I don’t have this option in my BIOS.

Another person recommended I try installing with Manjaro Architect. Any other suggestions?

Hello @manjomatcha :wink:

Did you try…

  1. updating the UEFI
  2. changing OS optimized defaults to “other OS” ?

Yes, the UEFI has the most recent update. There is no option to change the OS defaults.

I would show you a picture but it won’t let me post images or a link.

So I just realized that I had upgraded my SSD to a Crucial 1TB. I reverted back to the original SSD and the Manjaro installer had no problem finding the partitions.

You’ll likely need to disable fast startup from within Windows for the disk to become visible/accessible to the installer. The site I linked gives an example of the procedure. Hope this helps. :relaxed:

I did this already. I had recently upgraded my SSD to a Crucial P5 1TB and cloned my old Samsung 500 GB SSD (which came preinstalled on the laptop) with Windows to it. I tried updating the Crucial SSD firmware with the Crucial Executive Software but it wouldn’t update for some reason. I reinstalled my old SSD and the Manjaro saw the partitions just fine. I’m sending the Crucial SSD back and I ordered a Samsung EVO 970 Plus to see if that works any better.

Edit: I’m not sure if it was the cloning that messed it up, or just crappy firmware on the Crucial SSD. I used Macrium Reflect to clone the SSD with windows on it.

It could well have been the cloning process. Not sure what I used last time I cloned a Windows disk (it’s a long time ago) but it would have been either Acronis (True Image or Disk Director?) or Easeus Partition Manager/Master (whichever it was called).

The latter appeared to work but the resulting partition was corrupt and unuseable. Prior to that I had made successful clones using Acronis.

Maybe I’ll give Acronis a try next time. If it still doesn’t work, then I’ll just do a fresh install of Windows 10. What do you think could’ve gone wrong with the cloning that cause Manjaro to not recognize the partition?

Edit: I can’t get Acronis to download from their website. The download keeps failing. :frowning:
Edit 2: Never mind, it was ExpressVPN that was causing it to fail. I turned it off and was able to download it.

It’s possible that the cloning tool doesn’t overwrite the necessary sectors on the target disk, possibly for 2 reasons:

  • It may make existing partitions on a target disk inaccessible or unreadable
  • Unused space on a larger target disk might (without further intervention) be inaccessible.

What I’d do is set the target disk up first (e.g. create a GPT on it) using a partition manager from a Live session and then clone the partition(s) to it? Think that’s how I did it.

So let me get this straight… Boot a live session of Manjaro, set up a GPT on the new SSD, reboot into Windows on the old SSD, then clone Windows 10 to the new SSD, then install the new SSD in the computer and install Manjaro. Did I get that right?

I think so, but please don’t rely on it as it’s only a suggestion. There’s nothing to lose in trying!

I decided to just do a fresh install of Windows 10, shrink the partition within Windows and then install Manaro. It was much simpler that way.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.