Manjaro can't detect ds4 controller

Hey, I have a problem that I hope you will help me with.

I was using DS4 controller by USB on Manjaro for a lot of time, but recently i tried to connect controller again and Manjaro can’t detect it. In “input devices” in system settings i found:

No joystick device automatically found on this computer.
Check were done in /dev/js[0-4] and /dev/input/js[0-4]
If you know that there is one attached, please enter the correct device file

So i’ve checked:

ls /dev/input/
by-id    event1   event12  event15  event18  event20  event5  event8  mouse0
by-path  event10  event13  event16  event19  event3   event6  event9
event0   event11  event14  event17  event2   event4   event7  mice

Nothing on /dev/ too.

Controller is just glowing orange.

$ sudo dmesg
[ 1860.284515] usb 1-9: new full-speed USB device number 2 using xhci_hcd
[ 1860.601896] usb 1-9: New USB device found, idVendor=054c, idProduct=05c4, bcdDevice= 1.00
[ 1860.601903] usb 1-9: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1860.601906] usb 1-9: Product: Wireless Controller
[ 1860.601907] usb 1-9: Manufacturer: Sony Computer Entertainment
[ 1861.211892] sony 0003:054C:05C4.0005: failed to retrieve feature report 0x81 with the DualShock 4 MAC address
[ 1861.211956] sony 0003:054C:05C4.0005: hidraw4: USB HID v81.11 Gamepad [Sony Computer Entertainment Wireless Controller] on usb-0000:02:00.0-9/input0
[ 1861.211960] sony 0003:054C:05C4.0005: failed to claim input

Kernel: 5.15.49-1
Motherboard: Gigabyte b450m s2h
Processor: AMD 3 3300x
GPU: Nvidia 1050Ti

game-devices-udev package is installed, but in the past controller worked even without it.

Steam can’t detect controller too.

Tried on Windows 10 - controller worked.
Tried on live cd - didn’t worked.

Controller stopped working after i connected it to my friend’s laptop (via USB)

Would really appreciated if you help me.

Hey, check this AUR (en) - Packages list that you might need …

I’ve tried it, but it doesn’t helped.

You mean you followed this all the way ? Gamepad - ArchWiki

Yes, i followed it, but archwiki says that

The DualShock 3, DualShock 4 and Sixaxis controllers work out of the box when plugged in via USB

So it was before that time, now the controller is simply not detected by the system
and i can’t find it in input devices too.

Did you do this ?

For Steam to recognize your controllers, it needs to be able to read their device file. The steam package sets up udev rules for lots of controllers, but not the PlayStation 3 controller (aka. DualShock 3 controller). You can add the rules yourself:

# DualShock 3 controller, Bluetooth
KERNEL=="hidraw*", KERNELS=="*054C:0268*", MODE="0660", TAG+="uaccess"

# DualShock 3 controller, USB
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0268", MODE="0660", TAG+="uaccess"```

Nope, i don’t think steam can help me with it, because my system can’t recognize my controller (DualShock 4)
When controller worked fine without any issue (about 2 weeks ago) steam could detect the controller, and system too.

did u try installing steam-manjaro and removing the AUR steam package ? I brings with it steam-manjaro-udev-rules as dependency.
The udev rules are the ones creating your problems.

Fixed it using this github repo

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.