Manjaro can't create partition during installation

Hi I am trying to install manjaro
but I get the error

The Installer Failed to created partition on disk Hitachi HTS545032B9A302
Create New Partition (512.Mib , ext4) on /dev/sda
Job: Create New partition of device '/dev/sda’
Command: mkfs.ext4 -qf/dev/sda7

My latopt Specification

  Host: manjaro-gnome Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 
  Desktop: GNOME 3.38.4 Distro: Manjaro Linux 
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 8560w 
  v: A0001D02 serial: <superuser required> 
  Mobo: Hewlett-Packard model: 1631 v: KBC Version 01.39 
  serial: <superuser required> BIOS: Hewlett-Packard v: 68SVD Ver. F.25 
  date: 03/27/2012 
  ID-1: BAT0 charge: 46.1 Wh (100.0%) condition: 46.1/46.1 Wh (100.0%) 
  Info: Quad Core Intel Core i7-2720QM [MT MCP] speed: 1229 MHz 
  min/max: 800/3300 MHz 
  Device-1: NVIDIA GF108GLM [Quadro 1000M] driver: nouveau v: kernel 
  Device-2: Chicony Integrated HP HD Webcam type: USB driver: uvcvideo 
  Display: wayland server: X. org 1.20.11 driver: loaded: nouveau 
  note: n/a (using device driver) - try sudo/root 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: NVC1 v: 4.3 Mesa 21.0.3 
  Device-1: Intel 82579LM Gigabit Network driver: e1000e 
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi 
  Local Storage: total: 305.59 GiB used: 0 KiB (0.0%) 
  Processes: 284 Uptime: 1m Memory: 7.72 GiB used: 1.27 GiB (16.5%) 
  Shell: Zsh inxi: 3.3.04

Hello @sohail :slight_smile:

Please more information. Open a terminal and type:

inxi -Dazy 


sudo parted -l

and post the output here. thanks.

Response form
inxi -Dazy

  Local Storage: total: 305.59 GiB used: 24 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS545032B9A302 
  size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: C60Y scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: N/A size: 7.5 GiB block-size: 
  physical: 512 B logical: 512 B serial: <filter> rev: 2.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?

Response From
sudo parted -l

Model: ATA Hitachi HTS54503 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system     Flags
 2      1048kB  320GB  320GB   extended
 5      1049kB  224GB  224GB   logical   ext4
 6      224GB   228GB  3999MB  logical   linux-swap(v1)
 7      228GB   229GB  537MB   logical   ext4            boot
 8      229GB   320GB  90.9GB  logical   ext4
 1      320GB   320GB  512MB   primary   ext4

Model: VendorCo ProductCode (scsi)
Disk /dev/sdb: 8053MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2800MB  2804MB  4194kB  primary               esp

@sohail So you removed

and created a new partition on the same position? Or just reformatted it?

That is a bit strange… I see no real problem.

when I try to create partition its give me The Error
When installing i use the manually Installation to create two partition
7 228GB 229GB 537MB logical ext4 boot
8 229GB 320GB 90.9GB logical ext4
but i throw the Above error
I use Gparted to create the partition and reformat it but after the installation was finished my system Wont boot so i use the usb to boot my laptop Manjaro was installed but the disk was unmounted

What does this mean? Do you see the grub menu at boot?

take a look it the picture manjaro is installed in this partition but the partition is not mounted
right now i am chating to with from the live usb and without usd i wont boot up

Uploading: 20210516_000631.jpg…
this is what happen if i try to start my laptop with out live

yeah i understand that. So before you had sda1 as boot partition which is primary and root is at sda7 which a logical one. Now you want to have all in one partition at sda7, right?

The reason why it don’t boot, could be that the MBR is not written correctly or your BIOS did not support booting from a logical partition or the boot flag is not set, or you did not set the correct mountpoint.

Did you check the boot priority at your BIOS?

However… much less hassle would using a GPT Partition Table and using a bios_grub partition of 2MB at the beginning. Then if needed a boot partition and then a root partition. But downside is, you have ot wipe the whole drive and make a backup.

i dont understan bios that much this is my bios boot order

after the first black screen a few second later i get this screen

Did you install the MBR on /dev/sda or on /dev/sda7 ? It must be at your setup on /dev/sda.

Are you able to manjaro-chroot into your system from a live ISO?

If yes, I would try to restore the bootloader into the MBR (within chroot environment):

grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg

and reboot.

@Wollie @megavolt
my step of Installing
Step 1

Choose Manual partitioning
Step 2
Default Partition
Step 3
Createing Bootable Partition

Create root Partition

final Partition Look

on look

Final Step


@sohail Do you get the same error when you delete /dev/sda7 first and then create boot and root?

@sohail, have you booted the live ISO USB stick in BIOS or UEFI mode?

For a BIOS installation no /boot partition is needed by the way, also all the flags are obsolete.

@megavolt Yes i get the same error
@Wollie I have booted to iso in legacy Bios MBR

i think the is the problum with installer before the on 20.2 version i installed manjaro and everthing are fine

@megavolt @Wollie
I have tried manjaro 20.2 but still, end up with the same error I have Install Ubuntu and IWork Perfectly
I notice one thing though when I was burning ubuntu to USB all of these options were enabled but when I try to burn manjaro these option are disabled take a look at the image I am using rufus