Manjaro cannot be booted after the failed update

I updated the system with Tor because of internet restrictions in my place of residence

root # torsocks pacman -Syu

after the downloads were finished, I saw many errors related to the fact that this program cannot be installed with Tor and…

after that, everything was fine, until I rebooted the system and it didn’t come up anymore

I guessed that I messed up grub and reinstalled it with these commands in chroot tty, but it still didn’t work

root # pacman -Syu grub

root # grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck COPY TO CLIPBOARD

root # grub-mkconfig -o /boot/grub/grub.cfg

connect to internet, then chroot:
manjaro-chroot -a
rerun update:
pacman-mirrors -f 5 && pacman -Syyu
if there are no errors post output from:
mhwd-kernel -li && mhwd -l -li

I’ve been trying to update the system so far, and still no success. (The problem is low internet speed and severe restrictions).

I have two hard drives in my laptop, on each of which Linux Manjaro is installed separately. Could this be a problem? If yes, is it possible to remove one of the linux from the chroot and solve the problem?

What output is shown, when you try to update ?

error: failed to commit transaction (unexpected error)
Errors occured, no packages were upgraded

if i run it again:

dunst: /usr/bin/dunstify exists in filesystem (owned by dunstify)
python-numpy: /usr/bin/f2py exists in filesystem
python-numpy: /usr/bin/f2py3 exists in filesystem
Errors acoured, no packages were upgraded.

sorry bcz of img

you have these, so use everwrite:

 pacman-mirrors -f 5 && pacman -Syyu --overwrite '*'

also remove the 5.9 kernels, which are end of life; and remove also the linux54-rt:
pacman -R linux59 linux59-rt linux54-rt

and reinstall the 5.10 and 5.4:
pacman -S linux510 linux54

1 Like

All commanda done


It does not delete because of some dependencies

what dependencies… post output!