Manjaro Btrfs installation

Manjaro architect is discontinued for now. So is there any official way to install Manjaro with btrfs?

I don’t know about official, but with gparted you can partition your machine (keep it simple) and the calamares installer will accept and install with the manual option. Just set the boot flag for the right partition and it works. (installed on an old laptop this way last week where the kids play on so it seemed wise to have some automatic repair built in with timeshift-autosnap & grub-btrfs )

I edited partition.conf in /usr/share/calamares/modules/partition.conf and changed ‘defaultfilesystemtype’ to btrfs and installed Manjaro(gnome) with btrfs. Everything works fine except one strange thing. When I click suspend it goes to sleep & then when I try to wake it up it gets stuck with vendor/motherboard logo… nothing else…no tty… So I thought this is a problem with my method of installation… Though fstab had all required subvols and everything… :frowning:

Ah that is different question, suspend/sleep has a dependency on swap. How is your swap configured and does your log show any errors? It might be better to make a new thread with the right info

Already created 13 days ago

1 Like

Ah I see, I suggest adding some more info to the post and hardware info. Have you searched the forum for sleep related issues and researched some of the solutions that people posted?

<file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=083F-2213                            /boot/efi      vfat    umask=0077 0 2
UUID=57c15b6a-d5ad-4607-a733-06e8edb3380a /              btrfs   subvol=@,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 1
UUID=57c15b6a-d5ad-4607-a733-06e8edb3380a /home          btrfs   subvol=@home,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=57c15b6a-d5ad-4607-a733-06e8edb3380a /var/cache     btrfs   subvol=@cache,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=57c15b6a-d5ad-4607-a733-06e8edb3380a /var/log       btrfs   subvol=@log,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=4a94f0e8-01f8-4bcd-b0b5-170833ccf8a6 none		     swap    defaults 0 0

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=4a94f0e8-01f8-4bcd-b0b5-170833ccf8a6 udev.log_priority=3”

Intel Core i7-3770s
Nvidia GeForce GTX 1050 Ti
Nvidia Driver 460
Kernel 5.12

With ext4 I never had this issue…so I assumed the prob is with btrfs installation…

It looks good to me, resume points to the right UUID, swap is there. There is something with swap and btrfs that sort of nags in the back of my brain. Reading this & this seems to imply that a swapfile option should be a swapfile. However the swap option you post seems like a option I’ve not seen. Does your journal throw any helpfull errors when you recover from the previous session?


Is there resume at /etc/mkinitcpio.conf present at the hooks? like this:

HOOKS="base udev btrfs autodetect modconf block keyboard keymap filesystems resume"

Not using swapfile as I heard that it creates problem with timeshift backups. I added the swap partition later though…added resume=UUID=xxxx and updated grub and yes @megavolt I added resume hook after udev and regenerated initramfs. Also I used the minimal iso and apparmor wasn’t installed so I also installed that and added required things to grub.
I will look at the journal when it’ll happen again.

Just use a different subvolume like /@swap/swapfile and don’t put it on the root of /@/. Then there will be no problem with timeshift. Also disable compression and cow on that file.

I c…thanks…do I really have to use swapfile, removing the swap partition? It would b better if I can keep my current config (less work :crazy_face:)

add it after filesystems :wink:

No, that was just a clarification how it should work with a swapfile and btrfs.

1 Like

I have removed the UUID from grub, removed the swap entry from fstab and removed resume from modules. As I am using gpt, swap partition is mounted automatically… Now after suspend the pc starts normally… let’s see how it goes… Because it was also the case before, 3…4 time it resumed normally from sleep but then suddenly stopped working . These machines are hard to understand :frowning:

I am on Xfce now and I can confirm on Xfce suspend & hibernate is working just fine with btrfs but when I press hybridsleep button the same problem as gnome reappears, not waking up(black screen here instead of vendor logo on gnome)… So gnome suspend is actually hybrid sleep? I don’t need hybrid sleep… How to make gnome suspend act like Xfce suspend?

I guess both gnome3 and xfce uses systemd for suspend and hibernation. So in general there should be no difference.

hybrid-sleep works not for me, neither hibernation, but i deactivated at the BIOS anyway. Suspend works.

I would have a look at the logs and see where it hangs.

Try this on both installations:

systemctl suspend


systemctl hibernate

Then after wake up, or hard reset, have a look at the logs:

journalctl --since=-30m | grep -A9999 "Starting Suspend\.\.\." | grep "kernel:\|systemd\[\|audit\[\|systemd-sleep\[" 


journalctl --since=-30m | grep -A9999 "Starting Hibernate\.\.\." | grep "kernel:\|systemd\[\|audit\[\|systemd-sleep\[" 

As read on the Arch Wiki the hybrid-sleep thing is a mix of two worlds hibernation which is write-system-state-to-swap and suspend is write-system-state-to-ram.

As I understand the process

  1. system.idle → system supend-to-ram
  2. if the battery runs low it writes to swap and power off

When you build a system using btrfs - I assume that for the wake-up process to work - it would require the initramfs to be able to read the filesystem where the swapfile is stored.

Have you tried adding btrfs to the MODULES array in mkinitcpio.conf?

Just some - maybe - off-topic thoughts

There is a dilemma with sleep on LUKS encrypted systems - which I think is the same no matter the filesystem and that is the encryption and decryption of swap.

Now I am not that well versed in what full disk encryption can do and not do but from my readings.

With a LUKS encrypted system assuming you want your swap encrypted too then you are running a 5.xx kernel with btrfs support for swapfile on btrfs - you most likely run into the dilemma when hybrid-sleep powers off and you want to wake it up - there is no means of recovering because it requires unlocking of the storage holding the system image - maybe there is a kernel module you can put in mkinitcpio.conf?

1 Like

hibernate and suspend working but hybrid sleep isn’t working… how to provide the log for hybrid sleep??
I think the problem arises when the machine is trying to keep the data saved in the swap partition( hybrid-sleep) . I don’t use encryption.

Nope, Adding btrfs didn’t help.

Hybrid sleep is nice but not necessarily needed. I just want my pc to sleep if I am away from it for more than 30 mins.

journalctl --since=-30m | grep -A9999 "Starting Hybrid Suspend+Hibernate\.\.\." | grep "kernel:\|systemd\[\|audit\[\|systemd-sleep\["