Manjaro boots up with wrong screen resolution

Hello everyone!

Since kernel update (to 5.7) in August 12th, I’ve been having this problem: when my machine boots up sometimes it renders 1024x768, but the correct resolution is 1366x768. This is what I get from command “xrandr” after login:

Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
eDP1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
1366x768 60.00 + 48.02
1280x720 59.86 60.00 59.74
1024x768 60.00
1024x576 60.00 59.90 59.82
960x540 60.00 59.63 59.82
800x600 60.32 56.25
864x486 60.00 59.92 59.57
640x480 59.94
720x405 59.51 60.00 58.99
680x384 60.00
640x360 59.84 59.32 60.00
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
1366x768 (0x47) 76.319MHz -HSync -VSync
h: width 1024 start 1414 end 1446 total 1610 skew 0 clock 47.40KHz
v: height 768 start 771 end 776 total 790 clock 60.00Hz

To solve this problem I tried creating a file named “50-monitors.conf” in the “/etc/X11/xorg.conf.d” directory, but the problem persists. I have an intel graphic card, though I don’t know the specifics.

Thanks for reading all this. If someone could help me, I would be grateful.

Run arandr from any menu launcher, config the resolutions, aply, then use the icon in the menu to export the script, then add that script to you qtile config so it can run it on start up. Make sure that the script is executable with
chmod +x <script>

Thanks! It worked

Glad it worked!! Please mark the post solved if you can, so if anyone have the same problem could see it

Hi! The problem persists. The first and second time it boot up with the correct screen resolution but now it is happening again. I think the problem is with “lightdm” because the greeter sometimes starts up with 1024x768.