Manjaro bootloader not showing after Ubuntu upgrade

My manjaro bootloader isn’t showing up after I upgraded my Ubuntu which is dual booted with Manjaro.
OS: Manjaro 5.22.4
CPU: i3 7100U (2.4 GHz quad core)
GPU: Mesa Intel HD Graphics 620 (KBL GT2)
Device: Dell 5000 series

Earlier my manjaro bootloader used to come up after every boot, but I upgraded my Ubuntu with: sudo apt upgrade. After reboot, the manjaro bootloader wasn’t comming up. Instead, the original bootloader of Ubuntu ( just a black screen with options to choose manjaro or ubuntu) came up. Even if I choose manjaro, it just showed Dell logo for a long time and didn’t boot manjaro. Then I force shut it down.

To boot manjaro, I had to press F12 during boot before the Ubuntu bootloader showed ( which is like less than 5s ). Then the Manjaro bootloader would show and I have to choose manjaro (I changed the GRUB TIMEOUT to 30s and it works). I want to get the manjaro bootloader as I was getting earlier before the Ubuntu upgrade but can’t find a way out. Can I get some help in this ?

From within a running Manjaro system, issue the following commands… :arrow_down:

sudo grub-install
sudo update-grub

Yes it worked. Thanks a lot for help :hugs:. I guess my Manjaro’s GRUB was overtaken by my Ubuntu’s GRUB during upgradation. Do I have to do this every time I upgrade on Ubuntu ?

Yes, I’m afraid so. Ubuntu’s GRUB will attempt to take control, but as you could see, it cannot boot Manjaro. So you’ll have to let the Manjaro GRUB take control again every time you update Ubuntu. :man_shrugging:

This will be a headache now :disappointed_relieved:. It maybe because Ubuntu was installed earlier than Manjaro and I choose “Install alongside” during installation of Manjaro. So it treats Manjaro as a secondary OS and Ubuntu as primary. Is there a way to disable Ubuntu’s GRUB ?

Well, both of them do that to each other, and in and of itself, that wouldn’t be so bad if Ubuntu could also properly boot Manjaro. But Manjaro uses a customized GRUB, so it needs to be in control.

No, I’m afraid not.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.