Manjaro booting to black screen

Windows 10 and KDE Manjaro dual boot.
Boots to black screen with no errors after selecting Manjaro Linux in Grub bootloader.

I tried Deepin on Manjaro using a tutorial on Youtube (search " How to Install Deepin Desktop Environment in Linux Manjaro 18.0" on Youtube to find it as I can’t include links), but didn’t like Deepin. When I wanted to get rid of it, I booted to KDE and removed deepin package and everything that depended on it. (all the deepin applications, etc) I also removed lightdm. (big mistake??) I then deleted /etc/lightdm/lightdm.conf as I removed lightdm. After rebooting, black screen. Windows 10 works fine still.

How do I fix this?

That is some old video - at least a couple of years - don’t ever trust video tutorials -which is not current.

That doesn’t sound like a reinstall - more like a reconfigure

Depending on your drive and commitment - if that is not present - you don’t - best option is to reinstall.

If you are in for the learning experience - you have a lot of manuel work to do - and I don’t believe any member on this forum are going to hold your hands - next best option - reinstall.

If you are still in for the learning experience - you have a lot of reading to do - starting point could be

Maybe this entry point on the Arch Wiki

1 Like

I’ve marked this answer as the solution to your question as a reinstall is indeed your best bet…

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.