Manjaro boot entry missing from bios after power loss


after a power loss i can’t boot manjaro anymore. Is anybody willing to help resolving this?

So after the power loss (due to electricity/thunders and not system crashes) both the boot device selector (f11) and the actual bios don’t list manjaro, however the ssd is listed (samsung 970). Moreover, there’s an entry for windows boot manager which apparently is sitting in the same nvme ssd where manjaro is installed. It’s weird as I have never dual booted windows and manjaro from this ssd. I did have windows installed but on a separate drive and now it’s not installed on any of the drives. Booting that windows boot manager entry runs a windows recovery screen waiting for user choices.

From my limited understanding manjaro installation is still here. I can boot the system on the nvme by doing these steps:

  1. run configfile /boot/grub/grub.cfg from the grub terminal of a live usb booted in efi mode,
  2. grub starts,
  3. run a tty, log in and startx
  4. unlock the keyring and done.

  1. How can I fix the boot process?
  2. How can I remove windows boot manager from the system?

parted -l, boot flags are there…

Model: ATA WDC WD10EARS-00M (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name         Flags
 1      1049kB  1000GB  1000GB  ext4         wdc-storage

Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      1049kB  256GB  256GB  ext4         hope

Model: Samsung SSD 970 EVO Plus 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      2097kB  317MB  315MB  fat32              boot, esp
 2      317MB   500GB  500GB  ext4

lsblk -f

NAME        FSTYPE FSVER LABEL   UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda1      ext4   1.0   floppy  64ad383f-e840-4b8d-8ab7-a556d36abb70  270,4G    65% /media/floppy
└─sdb1      ext4   1.0   backups 0d45448e-c91b-4f4b-a164-d91f1df2d811  143,7G    33% /run/timeshift/backup
├─nvme0n1p1 vfat   FAT32         AB80-26AA                             273,9M     9% /boot/efi
└─nvme0n1p2 ext4   1.0           bcb016b9-027b-4187-892b-6b466779d375  228,3G    45% /

inxi -Fxxxza

System:    Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 root=UUID=bcb016b9-027b-4187-892b-6b466779d375 rw quiet 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: MSI model: X99S SLI PLUS (MS-7885) v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.F2 
           date: 06/13/2019 
CPU:       Info: 6-Core model: Intel Core i7-5820K bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3F (63) stepping: 2 
           microcode: 46 cache: L2: 15 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 79214 
           Speed: 2261 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 2261 2: 3427 3: 1733 4: 1355 5: 1492 6: 1275 7: 1252 
           8: 2026 9: 1569 10: 1610 11: 1271 12: 1201 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm 
           bus-ID: 03:00.0 chip-ID: 10de:13c2 class-ID: 0300 
           Display: server: X.Org 1.20.13 compositor: gnome-shell driver: loaded: nvidia display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.5x13.5") s-diag: 1108mm (43.6") 
           Monitor-1: HDMI-0 res: 2560x1440 hz: 60 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           Monitor-2: DP-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: Intel C610/X99 series HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:8d20 class-ID: 0403 
           Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 03:00.1 
           chip-ID: 10de:0fbb class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Intel Ethernet I218-V vendor: Micro-Star MSI driver: e1000e v: kernel port: f000 bus-ID: 00:19.0 
           chip-ID: 8086:15a1 class-ID: 0200 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.6 TiB used: 882.56 GiB (54.0%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7 temp: 48.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EARS-00MVWB0 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: AB51 scheme: GPT 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 6B0Q scheme: GPT 
Partition: ID-1: / raw-size: 465.46 GiB size: 457.16 GiB (98.22%) used: 205.61 GiB (45.0%) fs: ext4 block-size: 4096 B 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 25.5 MiB (8.5%) fs: vfat block-size: 512 B 
           dev: /dev/nvme0n1p1 maj-min: 259:1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 55 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 12% 
Info:      Processes: 324 Uptime: 1h 2m wakeups: 0 Memory: 31.26 GiB used: 3.17 GiB (10.2%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 alt: 10 clang: 12.0.1 Packages: pacman: 1698 lib: 385 flatpak: 0 Shell: Zsh 
           v: 5.8 running-in: gnome-terminal inxi: 3.3.06

You should try the following:
boot the Manjaro USB stick
chroot into the system (manjaro-chroot -a)
and run update-grub

Unfortunately update-grub is only going to update grub’s config file. To solve the problem you need to add again an UEFI entry for Manjaro. To do that you can boot the way you did, or you can boot the live USB and then execute the command manjaro-chroot -a. Then run the command:

sudo efibootmgr -c -d /dev/nvme0n1 -p 1 -L Manjaro -l \EFI\Manjaro\grubx64.efi

After that you can check that the entry has been added with:

sudo efibootmgr -v

If everything is right, reboot, and grub or your Manjaro should appear.

Alternatively you can reinstall grub from your Manjaro (EFI partition mounted in /boot/efi) with:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

And it will install grub to the ESP and add the UEFI entry for you.

Can’t thank you enough. I can boot normally now. Any ideas about removing the windows boot manager entry? Apparently the boot manager or the recovery partition is installed in my ssd with manjaro.

Screenshot of boot selector menu before reinstalling grub

Could I just remove /boot/efi/EFI/Microsoft directory? Besides data would it remove the boot entry in the uefi bios as well?

[cvn matteo]# du -h --max-depth=2 /boot/efi/EFI
140K	/boot/efi/EFI/Manjaro
136K	/boot/efi/EFI/boot
26M		/boot/efi/EFI/Microsoft/Boot
36K		/boot/efi/EFI/Microsoft/Recovery
26M		/boot/efi/EFI/Microsoft
26M		/boot/efi/EFI
[cvn matteo]#


You can remove the Windows entry with efibootmgr. Run first

sudo efibootmgr -v

and take note of the Windows boot entry number. Then run

sudo efibootmgr -b XXX -B

Being XXX the Windows entry number

You can also safely remove the Microsoft folder from the ESP

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.